Skip to Content
avatar image
Former Member

Webi User Prompt value showing Error# in the report output

Hi All,

I have a Webi report and my backend is a BEx query. When the report is executed through an instance it is taking the dynamic value for fiscalyear/period for the previous month (which is populated based on a user exit), but if i execute the report on demand by clicking the refresh icon and enter the fiscalyear/period it is showing Error# in the report display instead of month and year which was entered.

The formula which was used is

=Month(ToDate((Right(UserResponse([4 Wall];"Fiscal Period/Year");7));"MM.yyyy"))+" "+Right(UserResponse([4 Wall];"Fiscal Period/Year");4)

Appreciated if anyone could help me on this why it is throwing an error when it was run on demand.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Mar 22, 2017 at 02:18 PM

    it seems issue with your preferences. what is your "Locales and time Zone" preferences in BI Launch Pad?

    If it's "use browser locale" then change to specific country and try to run the report again.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 22, 2017 at 02:21 PM

    Hi Amit,

    The Locales and Time Zones are set to Use Browser locale, and current time zone set to local to web server.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 22, 2017 at 02:23 PM

    change it to for your country specific and try.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 22, 2017 at 03:09 PM

    Will test and let you know..Thanks for the prompt response.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 22, 2017 at 03:21 PM

    it's working..after changing the timezone in preferences.

    Add comment
    10|10000 characters needed characters exceeded