Skip to Content
avatar image
Former Member

SOAP Sender ADAPTER 401 No Authorisation

Hi all,

we want to make a PUBLIC webservice on our XI system. The problem is that we always need to give credentials when we do a post (XI username/password).

We don't want that, we've read info on SAP concerning this issue (SAP note 856597):

<i>The user authentication of the SOAP adapter is not part of the SOAP adapter but of the web container of the J2EE engine. The default authentication setting is defined in the web.xml descriptor file of the SOAP dapter web application. This setting may be modified from Visual Administrator with some restriction. Please refer to the security documentation for the J2EE engine.</i>

Does anyone of you knows how we can make our Web service a PUBLIC web service (without username/password credentials)...

TIA

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Sep 04, 2006 at 02:40 PM

    Peter,

    You can also post this question on WAS forum..

    Regards,

    Bhavesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Colin,

      I am also facing the similar problem. I don't want to enter the username and password exclusively, instead of that i want to pass along with the URL, which will hit the SOAP adapter.

      I have done the same way you suggested. But still it is poping login screen. Below is my URL:

      http://xisuper:welcome@xihost:<j2eeport>/XISOAPAdapter/MessageServlet?channel=:BS_EmployeeData:CC_EmployeeData

      Can you please suggest me, Still i need to do any settings..??

      Thanks.

      Muna.

  • avatar image
    Former Member
    Aug 31, 2007 at 03:20 AM

    Hi,

    Is there anybody know how to do

    set up a user id for this Web Service when you generate the WSDL in the Integration Builder.

    Many thanks,

    Add comment
    10|10000 characters needed characters exceeded