Skip to Content
-2

Prevent Invoice Output using Sales District

Hello, all,

I have an issue where one of our Sales Orgs wants to prevent Invoice printing based on a specific Sales District in their Sales Org.

I have the Output Determination set up, but I can't get it to stop creating output.

I need to have the Sales District in my higher-level conditions, or it will, naturally, fall to the lowest-level condition and print.

When I catch it by Sales District, how do I force it to NOT print? I tried Archive Only, but we don't have Archiving set up, and so that is not an option.

Thank you for any help you can provide.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Mar 21, 2017 at 09:54 PM

    Implement an output requirement routine. Similar questions have been asked on SCN numerous times, use Google, it's all out there.

    Add comment
    10|10000 characters needed characters exceeded

    • Sorry but output configuration is SD 101. You do need to know this even before you get to real work.

      Read also answer by Kıvanç Bilgin - if you can use output condition access sequence with SOrg/District then simply don't maintain condition records for those combinations when output is not needed. (This easier option slipped my mind somehow.) Otherwise there is no other option but to add a requirement routine.

  • Mar 22, 2017 at 01:52 PM

    Steve,

    Do you really want to prevent invoice printing for some districts, or do you actually want the condition record not to be created?

    How many sales districts do you have in your landscape? If not many, better change your condition table, and use one which uses sales district as a key field: Sales district (VBRK-BZIRK) is included in KOMKBV3 structure, so you can solve this without additional coding this way.

    If you have so many sales districts in your project, you'll need to follow Jelena's recommendation: Create a new requirement routine in VOFM. You can take a look at example program LV61B062 to see how it works.

    Add comment
    10|10000 characters needed characters exceeded