Skip to Content
author's profile photo Former Member
Former Member

WAD:chart axes problem

Hi Experts,

We have developed a charts(WAD) based on the query what we developed in BEX.But,in charts the X-axes what is available is default ie it is 2 keyfigures .But we need only one keyfigure.How to select only one kefgure on the X-axes.I tried all the option in the properties.Could you suggetst any other way.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Aug 31, 2006 at 10:14 AM

    Vassu,

    Usually the chart displays all that is there in the base query ,

    one way to overcome this is to open the query , remove the unwanted key figures and save it as a view. Now assign tis view to the chart web item and it should work properly.

    Arun

    Assign points if helpful

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Vasu,

      You can accomplish this by including Drop down box/Radio button group or Check box web item in the web template along with your Chart web item. In the Properties of the Drop down box/Radio button group or Check box web item, specify <b>Key Figures</b> in the <b>Characteristic/Structure</b> field.

      Web Item Properties -> Webitem Tab -> Specific -> Characteristic/Structures -> Select Key Figures here.

      Now you'll be able to select the Key Figures you want to display in the report.

      If both the web items are based on the same query, the Chart will display the Key Figure which you select in the Filter. Default option is ALL.

      If the queries are different, you've to check the data provider of the chart web item in the Affected Data Providers option of the Drop down box/ Radio button group/ Check box web item.

      Hope this helps.

      Regards

      Hari

  • author's profile photo Former Member
    Former Member
    Posted on Aug 31, 2006 at 01:02 PM

    Hi vasu,

    Try this.

    In the chart property set the other Series as

    visible->false.

    This will only display the first series as need by you.

    Hope it helps,

    Regards,

    Parth.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.