Skip to Content
0

JDBC Sender channel skips date fields when polling from SQL Server

Mar 21, 2017 at 11:13 AM

143

avatar image

Hi!

I have the weirdest problem with JDBC Adapter. In a JDBC->RFC scenario I poll some data record by record from MSSQL Server database using a SELECT query. I have each field specified in the query (not using * ).

Fields of type "date" however, are empty in payload. The same query executed in Management Studio returns all fields, including dates, but communication channel just skips them.

Have you experienced similar behavior? How to fix this issue? The only workaround I found was to include JDBC Lookup in mapping, where I select those missing fields seperately.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Luis Darui
Mar 21, 2017 at 04:42 PM
0

Have you tried using SQL Profiler to check the exact statement is being sent to SQL Server?

I suspect your problem might not be with the JDBC or SQL Server at all.

Share
10 |10000 characters needed characters left characters exceeded
Oliver Schönwald May 15, 2017 at 01:56 PM
0

We have got the same error after updating our SAP PI 7.31 to SP19. We are using some jdbc sender channels to read data from an Informix Database (Version 12.1). The IFlows and channels worked well just before the update to SP19.

Symptoms: SQL queries give empty result fields on SQL Date-fields although the source has defined date-values there.

Scale of problem: this seems only to happen with JDBC sender channels, not with JDBC receiver channels. Seems to be in relation to SP19 of SAP PI 7.31.

Workaround: Use SAP Note 2151731 and enforce the date format for the sender adapter in the advanced adapter tab. We set it to yyyy-MM-dd and the channels worked fine again after activating-

I think this is an error in SP19 and have reported this to SAP already.

Best regards,

Oliver Schönwald

University of Hagen

Share
10 |10000 characters needed characters left characters exceeded
bekir akturk Apr 17 at 12:45 PM
0

Hi Oliver,


Thanks for the answe. We got the same problem and solved according to your comment.

Share
10 |10000 characters needed characters left characters exceeded