Skip to Content
author's profile photo Former Member
Former Member

IMP: Error in transfer rules (alpha conversion)

Hi, I have 0material_attr for the custom field "vial size" in mara and into IOBJ "ZBVSZ". i am using conversion routine "ALPHA" and length 4 "char". I am getting the error as below.

<b>InfoObject /BIC/ZBVSZ does not contain alpa-conforming value 15</b>

can some one please help me with this..

Thank you very much

Emil

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 28, 2006 at 04:11 PM

    Note 598691 describes similar situation.

    from "alpha-conversion-problem

    "

    try this ...

    - go to transfer rule (info source)

    - check the flag for optional Alpha conversion (you should it on the left-hand side, at the very end "conversion")

    you will see the data will be loaded with any trouble afterwards, because the system will do the conversion for you :-8

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 29, 2006 at 06:24 AM

    Hi, You are getting the error because since the conversion routine alpha is used in your iobj 'zbvsz', whenever an incoming record has a pure numeric value, the system expects it to be padded with zero's if the value contains less than 4 char ( 15 in this case)

    To fix it you can check the conversion exit check box in the transfer structure as mentioned

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 28, 2006 at 04:06 PM

    hi,

    Could please tell me the input and output length of this charactertics.

    regards,

    meiy

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 28, 2006 at 08:00 PM

    Hi Emil,

    Enable the checkbox for "Conversion" in the transfer rules for your Zfield. This might do the needful. Hope this helps.

    Thanks and Regards

    Subray Hegde

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 29, 2006 at 05:02 AM

    Hi

    If you create this object as master data,check the alpha conversion coloumn in transfer rules..If it is not master data,simply remove the alpha conversion in info object maitainance...

    Hope it helps you...

    Thanks

    Teja

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.