Skip to Content
avatar image
Former Member

Receiver SOAP Adapter Exception

Hi Friends,

My scenario is RFC->XI->SOAP. When i send data to from R/3, in XI i am getting an error like....

- http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>Application</SAP:Category>

<SAP:Code area="UNKNOWN">APPLICATION_ERROR</SAP:Code>

<SAP:P1 />

<SAP:P2 />

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText>application fault</SAP:AdditionalText>

<SAP:ApplicationFaultMessage namespace="http://sap-j2ee-engine/error">com.sap.security.core.server.ws.service.WSSecurityException</SAP:ApplicationFaultMessage>

<SAP:Stack />

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

But We don't have any security settings to acess the webservice.. And i have also tested the webservice with XML Spy , it is working properly... I have also checked the target URL in Receiver SOAP Adapter.. Everything is fine. But still i am getting the error...

Regards,

Gowtham K.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 26, 2006 at 06:11 AM

    Hi Gowtham,

    Check out these threads..

    RFC -> XI -> External web service

    How to resolve this RFC_adapter_sender to SOAP_adapter_receiver Exception?

    Why getting "DeliveryExcetion" in SOAP->XI->RFC scenario?

    Hope ur problem gets solved!

    cheers,

    Prashanth

    P.S Please mark helpful answers

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Did you check the Inbound Message payload. I think you are using Sync so go to SXMB_ADM-->Integration Server Config and set the Trace Level = 3 and enable Logging. Since this is Sync you need to enable to see persist the message. Then you try the scenario and check SXMB_MONI you will get some clear idea. Try it and do let us know.

      Thanks,

      Prakash

  • avatar image
    Former Member
    Aug 26, 2006 at 06:19 AM

    Hi Gowtham,

    You need to specify the sap xi application user name and password in the altova xml spy (when you send a request to server).

    You may refer these fallowing weblogs

    /people/riyaz.sayyad/blog/2006/05/07/consuming-xi-web-services-using-web-dynpro-150-part-i

    /people/siva.maranani/blog/2005/09/03/invoke-webservices-using-sapxi

    Add comment
    10|10000 characters needed characters exceeded