Skip to Content
0

create item icon is not shown in Portfolio dashboard for 1 portfolio

Mar 20, 2017 at 02:35 PM

184

avatar image
S T

Hi Experts,

We have 4 portfolios. When I try creating PPM item for 1 portfolio then I am able to see 'Create' button in dashboard as shown below:

dashboard-1.png

When I change portfolio (to a different portfolio) then this 'Create' icon disappears as shown below:

dashboard-2.png

Could you please tell me what's wrong here and how can we address this issue?

Best Regards

Saurabh

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Francesco Pezzoli
Mar 24, 2017 at 01:04 PM
0

Hello Saurabh,

Have you confirmed that your user is authorised to create items in the affected portfolio? Try assigning "Admin" authorization to the user for the portfolio and see if the user is now able to create items from the portfolio's item dashboard.

Best regards
Francesco

Share
10 |10000 characters needed characters left characters exceeded
S T Apr 12, 2017 at 02:41 PM
0

Hi Francesco,

Yes, Authorization related checks I have done already.

I Found the reason of this behavior: Under parent Portfolio there is a classification hierarchy created for this parent portfolio. What surprises me is that Parent Portfolio and it's assigned classification hierarchy has same identification (3000) and when i try to delete this classification hierarchy 3000 it says" Portfolio 3000 is the current portfolio and cannot be deleted"

Only this Portfolio has classification hierarchy assigned in it. Rest other Portfolios has no classification hierarchy and we are able to see 'create' button there.

any pointers?

Thanks

Saurabh

Share
10 |10000 characters needed characters left characters exceeded
Francesco Pezzoli
Apr 14, 2017 at 12:09 PM
0

Hello Saurabh,

As far as I could see, that should not normally be possible: if I try to create a classification hierarchy which has the same ID as a portfolio which already exists, I get error message "ID ... already exists and cannot be duplicated". It is odd that this was possible on your system.

Have you tried to change the ID of the classification hierarchy, to see if that helps?

Best regards

Francesco

Share
10 |10000 characters needed characters left characters exceeded
S T Apr 14, 2017 at 03:47 PM
0

Hi Francesco,

Yes, I tried changing the ID of classification hierarchy but it changes the ID of Portfolio also to which it is assigned. :(

I tested by creating new Portfolios and classification hierarchy below to them but I dont get the same case replicated there.

As a workaround, I have activated 'Create' button to this case with WebDynpro ABAP but still unable to find the root cause of this issue.

Looks to me some inconsistency has caused this issue. Do we have any standard program OR a SAP note that we can run to fix such an inconsistency?

Any thoughts please?

Thanks & Regards

Saurabh

#need you expertise in another thread Francesco: https://answers.sap.com/questions/178489/item-status-number-is-shown-instead-of-text-on-ppm.html

could you please update your comments on this issue too?

Thanks

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Saurabh,

I have never seen this kind of inconsistency before. I would rule out that there is an existing note or correction report about this (I have searched and could find nothing). As you also cannot replicate the creation of the inconsistency, there is not much that we can do in terms of a root cause analysis or providing a standard solution.

Please check database table /RPM/PORTFOLIO_D with transaction SE16: do you really have two different entries with the same EXTERNAL_ID value, one with flag HIERARCHY and one without flag HIERARCHY?

- if yes, then a correction of the inconsistency would simply require to change the value EXTERNAL_ID for the entry which has the "HIERARCHY" flag. I think your basis team or developer should be able to write a simply ad-hoc program that does this. After doing so, you should check if everything works in the frontend or if you have some issues/dumps, in which case you should revert the change (making a table backup before running the report would also be good idea).

- if no, i.e. there is only one entry with this external ID and this entry has flag "hierarchy", then we are looking at one single classification hierarchy here (i.e. there is no such portfolio). In this case I can only suggest that you create a new portfolio which you can use instead of the classification hierarchy (per the program design, you cannot create any items in a classification hierarchy, you can only assign existing items to one via item tab "classification).

Best regards

Francesco

0
S T Apr 19, 2017 at 01:44 PM
0

Hello Francesco,

There is only one entry with Portfolio ID. I checked table /RPM/PORTFOLIO_D and I found 'classification' field is blank against this ID i.e. it is not a classification hierarchy. :( When I check in PPM portal, I see classifcation hierarchy 2000 is assigned to Portfolio ID 2000.

ID 2000 is for both portfolio and classification :( . I don't understand how system has allowed such a data to get saved.

Best Regards

Saurabh

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Saurabh,

I think someone at SAP Support will need to look at the data on your system in order to understand exactly what is the issue and what can be done about it. I would recommend that in this case you open an incident. If you write the incident number here, I may be able to pick it up myself or ask someone to continue from here.

Best regards

Francesco

0

Hi Francesco,

Agreed! But, we have already enhanced PPM item dashboard screen to activate it through WDA and it could probably be difficult for SAP to have a say on this object as it's already enhanced by us.

In case, you or we find any concrete reason/solution on this we will update it here.

Thanks & Regards

Saurabh

0