Skip to Content
0

SAP Persona - Custom ALV Tables could not be edited

Mar 17, 2017 at 04:54 PM

222

avatar image
Former Member

Hi Experts,

I am working on SAP Persona 3.0 in which I am editing the flavors for the custom screen where the custom ALV table is placed. I could select all the objects/ fields/ buttons in the screen. But I could not select the ALV table or resize the ALV container. If I select the ALV table, it selects the whole page of the screen. It also happens when I try to select the table in standard screen. I am giving the standard table examples below.

The Standard Buttons could be editable in edit mode but the ALV Tables.

Please help me to understand what causes this non-editable/ non-selectable table.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Tamas Hoznek
Mar 17, 2017 at 07:47 PM
0

It is not immediately obvious which control / object is selected on the first screen shot. But in such situations, the first question to ask is always whether you have the latest Personas client note version implemented.

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Tamas,

The first screen, I clicked on the table column to choose or to select the table. The Persona client has all the latest note version implemented. I just checked with the Basis team.

Thanks.

Regards,

Geerthi D

0

What I meant is that in the screen shot, the type of the selected control is not visible. Is it indeed the grid or maybe something else?

I would verify which version of the client note is installed... sometimes it turns out that it is not up-to-date, despite the claim.

0
Former Member

The First screen has the selected control of "List of Contracts" blue lined container, whereas I was clicking the table just below the horizontal scroll bar.

I once again verified with the Basis team and the all the latest notes were installed. The same notes were installed in the different system (Test), it worked fine, I could select the table there. Please help.

0

The best course of action would be creating an incident and opening the service connections, because it is difficult to assist with this kind of an issue without being able to see what is happening in the system.

0
avatar image
Former Member May 18, 2017 at 03:40 PM
0

I checked with the notes versions. The reapplying of the notes and restarted services actually solved the issue. Again It was gone through Basis and I am not given the list of notes they reapplied. I believe it was the entire list of notes.

Share
10 |10000 characters needed characters left characters exceeded