Skip to Content
0

Catalog Services unavailable in WebIDE Personal Edition

Mar 17, 2017 at 04:05 PM

3.5k

avatar image
Former Member

I have a done a local installation of SAP WebIDE personal edition. I have created an ODATA Service which I would like to be able to connect with my template Fiori app. We have an on premise setup.

I am returned this error regardless of any changes I make.

I want give you guys a reference of the text document with the destinations.

Thank you.

config.png (10.6 kB)
config.png (13.1 kB)
10 |10000 characters needed characters left characters exceeded
Former Member

I went and checked if the version 2 (v=2) catalog service is working. I can confirm that when I pull it up using the link below (image) it does work.

working-v2-catalog-service.png(6.6 kB)

However, the webide gives an error because it is asking for the link

Therefore, the destination file is pointing it the wrong way.

Here is the destination file that I am using. Feel free to give suggestions.

When I go to maintain services menu, I see that the catalog service has no local system alias and it does not allow me to add one either.

Could this be the potential problem? that the webide server cannot point to the catalog service? If anybody has different ideas please let me know.

0
* Please Login or Register to Answer, Follow or Comment.

10 Answers

Krishna Kishor Kammaje
Mar 18, 2017 at 10:50 AM
1

You need a colon before port number.

\:8012

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I changed it as you asked. I have checked that the catalog service is running perfectly (saw it in the GUI, as well as opened it up in the browser). So it is my understanding that what is wrong must be wrong in the configuration file. I have added the semicolon and it gives the exact same error.

Furthermore, we do have authentication on our ewp system. Is NoAuthentication still the right option in such a case?

fixed-config.png (10.0 kB)
0

Hope you use basic authentication for authenticating with SAP.

When you select the destination, a pop-up will ask you to enter the credentials. So 'NoAutentication' is not an issue.

Also, can you try below things?

- WebIDESystem=EWP (uppercase)

- WebIDEUsage=odata_abap,odata_gen,ui5_execute_abap,dev_abap,bsp_execute_abap

0
Former Member

I did a use caps EWP. Now I took a look at the catalog services and I see 2 catalog services.

Then I diagnosed another aspect of the issue.

If you can see what it is trying to pull up. Something is going wrong. Take for instance that it is trying to pull V=2 of the catalog service.

Will add more as I find more. I really hope someone has had this issue before. I am not sure why there are two catalog services, and I am unable to delete the second one, this is the error I get:

0
avatar image
Former Member May 24, 2017 at 11:32 AM
0

Hello Shashank,

Could you find a solution for the problem. I have the same issue, any help is appretiated

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

No answer has been found personally by me. I have completely pivoted to making the application in eclipse and running it off the ABAP server. SAP's sparse and inadequate documentation makes using the WebIDE Personal Edition a gigantic waste of time. Nobody whom I work with knows about the issue. Furthermore, making threads about it ends up in dead threads and no SAP moderators come out and answer the question.

I personally think you have two options:

A. Use the cloud connector and use the HANA Cloud Platform. This likely won't be possible with an on-premise setup because of security concerns.

B. Use eclipse and develop on premise, its slower and deeply painful compared to webIDE, but this is the solution I have taken up. It's the only choice I saw as reasonable. If you need any further help, please let me know.

0
Former Member

ok thank you very much for your answer.

0
0
saurabh vakil May 25, 2017 at 09:39 AM
0

Check if you can find the service /IWFND/SG_MED_CATALOG in your front end server. If this service is not active then activate it. I found that activating this OData service gets rid of the catalog service unavailable error in Web IDE.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

will try after the long weekend. Thank you.

0
Karthik Gali Jul 20, 2017 at 01:10 PM
0

Deleting the alias maintained for the Catalog service resolved my issue.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Aug 09, 2017 at 03:21 AM
0

Guys,

Could you let me know the exact solution? I also face similar issue 'Catalog service is unavailable' in WebIDE.

Thanks

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Deleting the alias maintained for the Catalog service resolved my issue.

0
avatar image
Former Member Sep 12, 2017 at 05:38 AM
0

Hi Shashank,

Please try with below configuration format, it works for me.

Name=<Name>

Description=<Description>

Type=HTTP

TrustAll=true

Authentication=BasicAuthentication

User=<Username>

Password=<Password>

WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap,odata_gen

URL=http://<host>:<port>/

ProxyType=OnPremise

WebIDESystem=<SID>

WebIDEEnabled=true

sap-client=<Client>


Also the destination text file should not have any extension.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 20, 2017 at 11:57 PM
0

Hi Shashank,

you check the log in your cloud connector, maybe you need to add another resources in your system mapping.

Share
10 |10000 characters needed characters left characters exceeded
Sonia Kalra Dec 08, 2017 at 08:15 PM
0

Did anyone find answer to this as I can see two versions of /IWFND/SG_MED_CATALOG service in /iwfnd/maint_service and bot the version seem to be activated but when I try to connect local web ide with on premise system I am getting the same error and error_log in the back end shows authorization missing for version 0002 but looks like security does not see service with version 0002 available to them for adding to my user id.

Any help is appreciated.

Thanks

Sonia

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 06 at 05:09 AM
0

Is it resolved? If so, can you please share the details..

Share
10 |10000 characters needed characters left characters exceeded
Sriram Chakravarthy Jayaprakash Jun 28 at 12:40 AM
0

1) Activate services /IWFND/SG_MED_CATALOG.

2) Delete the system alias for service /IWFND/SG_MED_CATALOG.

3) Configure the destination file with the below details.

Name=<Name>

Description=<Description>

Type=HTTP

TrustAll=true

Authentication=BasicAuthentication

User=<Username>

Password=<Password>

WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap,odata_gen

URL=http://<host>:<port>

ProxyType=OnPremise

WebIDESystem=<SID>

WebIDEEnabled=true

sap-client=<Client>

Share
10 |10000 characters needed characters left characters exceeded