Skip to Content
avatar image
Former Member

Catalog Services unavailable in WebIDE Personal Edition

I have a done a local installation of SAP WebIDE personal edition. I have created an ODATA Service which I would like to be able to connect with my template Fiori app. We have an on premise setup.

I am returned this error regardless of any changes I make.

I want give you guys a reference of the text document with the destinations.

Thank you.

config.png (10.6 kB)
config.png (13.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Former Member

    I went and checked if the version 2 (v=2) catalog service is working. I can confirm that when I pull it up using the link below (image) it does work.

    working-v2-catalog-service.png(6.6 kB)

    However, the webide gives an error because it is asking for the link

    Therefore, the destination file is pointing it the wrong way.

    Here is the destination file that I am using. Feel free to give suggestions.

    When I go to maintain services menu, I see that the catalog service has no local system alias and it does not allow me to add one either.

    Could this be the potential problem? that the webide server cannot point to the catalog service? If anybody has different ideas please let me know.

  • Get RSS Feed

10 Answers

  • Mar 18, 2017 at 10:50 AM

    You need a colon before port number.

    \:8012

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I did a use caps EWP. Now I took a look at the catalog services and I see 2 catalog services.

      Then I diagnosed another aspect of the issue.

      If you can see what it is trying to pull up. Something is going wrong. Take for instance that it is trying to pull V=2 of the catalog service.

      Will add more as I find more. I really hope someone has had this issue before. I am not sure why there are two catalog services, and I am unable to delete the second one, this is the error I get:

  • avatar image
    Former Member
    May 24, 2017 at 11:32 AM

    Hello Shashank,

    Could you find a solution for the problem. I have the same issue, any help is appretiated

    Add comment
    10|10000 characters needed characters exceeded

  • May 25, 2017 at 09:39 AM

    Check if you can find the service /IWFND/SG_MED_CATALOG in your front end server. If this service is not active then activate it. I found that activating this OData service gets rid of the catalog service unavailable error in Web IDE.

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 20, 2017 at 01:10 PM

    Deleting the alias maintained for the Catalog service resolved my issue.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 09, 2017 at 03:21 AM

    Guys,

    Could you let me know the exact solution? I also face similar issue 'Catalog service is unavailable' in WebIDE.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 12, 2017 at 05:38 AM

    Hi Shashank,

    Please try with below configuration format, it works for me.

    Name=<Name>

    Description=<Description>

    Type=HTTP

    TrustAll=true

    Authentication=BasicAuthentication

    User=<Username>

    Password=<Password>

    WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap,odata_gen

    URL=http://<host>:<port>/

    ProxyType=OnPremise

    WebIDESystem=<SID>

    WebIDEEnabled=true

    sap-client=<Client>


    Also the destination text file should not have any extension.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2017 at 11:57 PM

    Hi Shashank,

    you check the log in your cloud connector, maybe you need to add another resources in your system mapping.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 08, 2017 at 08:15 PM

    Did anyone find answer to this as I can see two versions of /IWFND/SG_MED_CATALOG service in /iwfnd/maint_service and bot the version seem to be activated but when I try to connect local web ide with on premise system I am getting the same error and error_log in the back end shows authorization missing for version 0002 but looks like security does not see service with version 0002 available to them for adding to my user id.

    Any help is appreciated.

    Thanks

    Sonia

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 06 at 05:09 AM

    Is it resolved? If so, can you please share the details..

    Add comment
    10|10000 characters needed characters exceeded

  • 1) Activate services /IWFND/SG_MED_CATALOG.

    2) Delete the system alias for service /IWFND/SG_MED_CATALOG.

    3) Configure the destination file with the below details.

    Name=<Name>

    Description=<Description>

    Type=HTTP

    TrustAll=true

    Authentication=BasicAuthentication

    User=<Username>

    Password=<Password>

    WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap,odata_gen

    URL=http://<host>:<port>

    ProxyType=OnPremise

    WebIDESystem=<SID>

    WebIDEEnabled=true

    sap-client=<Client>

    Add comment
    10|10000 characters needed characters exceeded