Skip to Content
0
Former Member
Aug 21, 2006 at 09:10 PM

Error while installing Java on Web AS ABAP on AS/400

20 Views

Hi ,

I am trying installation of Java Add-Ins on Web AS ABAP.

Installation is being done on IBM iSeries server having operating

system OS/400.

But when I am supplying JDK path in setup , It is showing me

error "Directory given in path is not a valid JDK directory."

I went through all the relevent notes but it could not resolve the

problem.

This error has not occurred while I have done installation on

development system , And Whole installation has been completed

successfully on Development system. But on production system it is

giving this error.

By going thourgh SAPInst_dev.log, It seems me that It is an error in

creating a new stub job by TMKSVR.

Find the following sample log for your reference from sapinst_dev.

*****************************************/

TRACE [synxctask.cpp:345]

CSyTaskImpl::start(false)

OS4Trace: "E:\QIBM\ProdData\Java400\jdk14/bin/java" does not exist or

is no Windows executable. Checking remote iSeries host.

TRACE [synxctask.cpp:448]

CSyTaskImpl::start(false)

OS4Trace: "/QIBM/ProdData/Java400/jdk14/bin/java" is an existing IFS

object. Creating remote iSeries process.

TRACE [synxctask.cpp:592]

CSyTaskImpl::start(false)

OS4Trace: Could not create new TMKSVR stub job named "java".

INFO 2006-08-17 14:59:13

CJSlibModule::writeInfo_impl()

Execution of the command "E:\QIBM\ProdData\Java400\jdk14/bin/java '-

version'" finished with status TST_ERROR.

INFO 2006-08-17 14:59:13

CJSlibModule::writeInfo_impl()

Execution of the command "E:\QIBM\ProdData\Java400\jdk14/bin/java '-

version'" finished with return code -1. Output:

/*****************************************/

This is some portion of error.

Following sentance seems to me , which may be root .

<b>CSyTaskImpl::start(false)

OS4Trace: Could not create new TMKSVR stub job named "java".</b>

And I checked in log files for TMKSVR , There are not stub log files

has been created for this command. So it seems new stub job is not

being created.

I am not able to proceed for installation due to this error.

Please suggest some solution at the earliest.

Regards,

Rajesh Patel

mail to : rajesh.patel@tcs.com

(m) 001-619-886-4149