Skip to Content
0

HTTP Sender - 500 Internal Server Error- SAPI Single stack

Mar 17, 2017 at 02:17 PM

252

avatar image
Former Member

Hi Experts,

We are having following requirement.

HTTP(S) call from Bank's server to hit SAP PI Single stack using HTTP Adapter.

Bank'server (HTTPS) Call ----> SAP PI ---> ECC

We have generated the URL for HTTP_AAE adapter and shared the url.

We are getting 500 Internal Server error while trying to hit the same at browser level and also from Bank's server level also.

What are the factors to be considered to resolve this issues. Kindly help.

Best Regards,
Suresh S

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Andrzej Filusz Mar 17, 2017 at 03:12 PM
0

Hi Suresh,

Have you tried to access the HTTP adapter from your local network (not from the Internet)? I mean, using a local host name and port, not the DNS name? I would like to make sure that there is no problem with the network configuration between your system and the Internet (firewall, reverse-proxy, etc.). If you would be able to connect from your local network, then you should talk with your network/security team. Otherwise, you will have to check message monitoring/log and traces on your system.

Regards,

Andrzej

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 26, 2017 at 01:27 PM
0

Hi Andrzej,

Issue was due to space in Endpoint url , partner used to hit PI url . Now they are able to reach PI system successully.

Thank you for your inputs.

Best Regards,
Suresh S

Share
10 |10000 characters needed characters left characters exceeded