Skip to Content
0

Cannot start SAP SMS Builder 1.3.5 Server

Mar 17, 2017 at 12:24 PM

58

avatar image
Former Member

Hi;

I am working on setting up SAP SMS Builder on my development machine, but am having challenges getting the Brand server to start. The server is getting stuck at the point shown below:

Below are the error on the log files:

Fri Mar 17 14:07:56 CAT 2017 Thread[FelixStartLevel,5,main] Fri Mar 17 14:07:56 CAT 2017 Thread[FelixStartLevel,5,main] Startup failed due to missing functionality for org.apache.derby.jdbc.InternalDriver. Please ensure your classpath includes the correct Derby software. ERROR XBM02: Startup failed due to missing functionality for org.apache.derby.jdbc.InternalDriver. Please ensure your classpath includes the correct Derby software. at org.apache.derby.iapi.error.StandardException.newException(Unknown Source) at org.apache.derby.iapi.services.monitor.Monitor.missingImplementation(Unknown Source) at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source) at org.apache.derby.impl.services.monitor.BaseMonitor.bootService(Unknown Source) at org.apache.derby.impl.services.monitor.BaseMonitor.startServices(Unknown Source) at org.apache.derby.impl.services.monitor.BaseMonitor.runWithState(Unknown Source) at org.apache.derby.impl.services.monitor.FileMonitor.<init>(Unknown Source) at org.apache.derby.iapi.services.monitor.Monitor.startMonitor(Unknown Source) at org.apache.derby.iapi.jdbc.JDBCBoot.boot(Unknown Source) at org.apache.derby.jdbc.EmbeddedDriver.boot(Unknown Source) at org.apache.derby.jdbc.EmbeddedDriver.<clinit>(Unknown Source) at org.apache.derby.osgi.EmbeddedActivator.start(Unknown Source) at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:645) at org.apache.felix.framework.Felix.activateBundle(Felix.java:1977) at org.apache.felix.framework.Felix.startBundle(Felix.java:1895) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Unknown Source)

What am I doing wrong or rather what am I not doing? I have gone through the documentation but it doesn't give me much in terms of setting up the development environment, that is, setting up the DB.

I'm on SMP 3.0 SP14 SDK Patch 0

Much appreciated!

Thanks and Regards;

Sizo Ndlovu

runbat.jpg (92.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member
Mar 30, 2017 at 09:08 AM
0

HI Sizo

As there are ports etc required for coms to the DB, can you confirm that the required ports are not being blocked by Antivirus ? Perhaps start by temporarily disabling and running the startup script as an administrator.

Good Luck

Lyle

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Jul 12, 2017 at 12:05 PM
0

Hi Sizo,

Any luck running this. I am also facing the same issue.

Thanks & regards,

Lalit

Share
10 |10000 characters needed characters left characters exceeded