Skip to Content

How to Export Dimension Master data from BPC10.0 into flat File

Hi Experts,

I have created one Test environment for Back up Purpose into our BPC development system. No i wanted to export all the dimensions master data into a flat file from production system and the same i wanted to import it into test environment of development system.

1. How to create Transformation file for exporting of Dimension master data. Can you please give me an example? I am specially looking for Mapping section.

2. Similar question while importing the same data to development system?

3. Please give me any dimension example e.g. Product , Account or Organisation. Also While exporting master data , hierarchy also get exported into flat file?

I am trying to export master data using data manager package but it is asking for transformation file. Hence looking for an example format of transformation file. Kindly advise.

Regards,

Parag

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Mar 21, 2017 at 09:02 AM

    Your issue is due to commas inside the properties:

    APPROVER: [AP_w_FPA],[T3 - Business Supp]

    and

    OWNER: [AP_w_FPA],[T3 - Business Supp]

    In the transformation file *OPTIONS use:

    DELIMITER = TAB

    instead of:

    DELIMITER = ,

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 17, 2017 at 12:23 PM

    Sorry, but it's absolutely basic question - why not to search a little or read help?

    Put nothing in the mapping section :) Everything will be exported! Just test yourself

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Vadim,

      Actually when i exported data into flat file that time system didnt picked up hierarchy i.e. PARENTH1. So while importing same file into dimension in development system , it picked up [T3 - Business Supp] as PARENTH1 (This was my understanding).organisation2.jpgorganisation1.jpg . So the question is why it is not showing PARENTH1 members in a file?

      I am attaching screen shot from Organisation dimension.

      So as per your comment i need to export data first using below transformation option i.e. Delimiter = TAB. And once exported then import this file with the same option?

      *OPTIONS FORMAT = DELIMITED HEADER = YES DELIMITER = TAB AMOUNTDECIMALPOINT = . SKIP = 0 SKIPIF = VALIDATERECORDS=YES CREDITPOSITIVE=YES MAXREJECTCOUNT=-1 ROUNDAMOUNT=

      One more question here. I did try with same exported file having "," but changes done in transformation file as suggested. This time Import Data manager Package again fail but error is different.

      ERROR: Invalid header name: "ID,ALLOC_PRE_OSS_EXCEPT,ALLOC_SP2_ALLOC,ALLOC_SP2_".

      Do i need to remove header from the file?

      Many Thanks for your quick response and support.

      Parag

      organisation2.jpg (46.6 kB)
      organisation1.jpg (38.5 kB)
  • Mar 21, 2017 at 09:42 AM

    "So as per your comment i need to export data first using below transformation option i.e. Delimiter = TAB. And once exported then import this file with the same option?"

    Yes! I think I have explained it absolutely clear.

    You can't use comma delimiter if you have commas inside property values.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 21, 2017 at 10:24 AM

    Thanks Vadim. I have followed as you instructed. Now no more Org member related error. But as i mentioned in my previous reply i am getting header related error and hence package is getting fail. Do i need to remove header from file?

    ERROR : Invalid header name: "ID,ALLOC_PRE_OSS_EXCEPT,ALLOC_SP2_ALLOC,ALLOC_SP2_"

    Parag

    Add comment
    10|10000 characters needed characters exceeded

    • Many Many Thanks Vadim. Yes your solution worked and without any issue i could able to import entire master data. This is not only help from your end but i got few important tips regarding transformation file too. Will proceed with Account dimension now and if found any issue first will research on it and then will trouble you again :)

      Parag