Skip to Content
2

SAP Cloud Platform Cannot connect to On Premise via Cloud Connector

Mar 17, 2017 at 10:05 AM

605

avatar image

Hi All,

I have installed the SAP Cloud Connector in a cloud server and have configured it to connect to the HANA Trial Account and also the Backend system.

I can see the SAP Cloud Connector in my Cloud Platform and also the backend system is reachable.

But when I configure the destination and try to check for connection I get the error "Failure Reason:Backend system status cannot be determined", so I tried to check if the request from Cloud Platform reached Cloud connector. I used a network data tracking software and tried to see if there are any network traffic when I try the check connection but I did not get any data from the SAP Platform in to the SAP Cloud connector.

I am not sure if this is the right way to check if the request from Cloud Platform reaches Cloud connector, if anybody knows any other way please let me know so that I can check it.

I have added the scree shot of mapping & configurations, please have a look at it and let me know if anything is wrong.

fullview-configuration.png

Thanks in Advance.

George.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Kulandai George Maria Singarayar Mar 21, 2017 at 08:13 AM
1

I found the issue and corrected it,

I did not set the paramter CloudConnectorLocationId = "LocationID" (this will be specified in the SCC during HTTP destination configuration), so after setting this i got the message that "Success: Connection to "mysystem" successful".

Thanks to all who viewed and thought about helping with a solution.

Share
10 |10000 characters needed characters left characters exceeded
Gregor Wolf
Apr 04, 2017 at 04:30 PM
1

Hi Kulandai,

I'm facing the same issue (SCP Trial) I thought that the field "Location ID" on the left side of the screen should work. But only after maintaining CloudConnectorLocationId the connection works:

Hope that someone from the SAP Cloud Platform Team looks at this and the error get's fixed soon.

Best regards
Gregor


Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Gregor,

Thanks for the reply, I am using the latest version of the Cloud Connector 2.9.0.2 which does not have the Location ID in the main parameter list, And yes i was able to connect only after setting the CloudConnectorLocationID property which is not available in the dropdown list which must be added.

Thanks,

George.

0

Hi Gregor, hi Kulandai,

indeed you still need the additional property CloudConnectorLocationId to define the Cloud Connector in the destination. We are working on making the Location ID a standard field (left side). I will update the blog as soon as it works fine for HTTP. RFC should work already.

Thanks for your feedback.

Matthieu

1

Update: You don't need the additional property CloudConnectorLocationId anymore. The standard field Location ID is working since a couple of weeks now ;)

Best,

Matthieu

0
Matthieu Pelatan
Apr 05, 2017 at 09:15 AM
0
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Matthieu,

Thank you for your response, I was able to connect by setting the the property CloudConnectorLocationId only after reading your blog. I think this must be listed among the properties and also must be documented in the HTTP destination configuration guides.

-George.

0