Skip to Content
0

Unable to activate repository objects/Artifacts in SAP HANA workbench (Editor)

Mar 17, 2017 at 09:17 AM

96

avatar image

Hello,

We are having some problem in one of our HANA instance on SAP cloud platform

We are trying to activate our artifact files on the workbench but the system only saves that file but could not activate that.

Same kind of issue is mentioned here: https://archive.sap.com/discussions/thread/3778178

we also tried to restart the database but doesn't solve the problem. Kindly check error code in the screenshot provided and provide your valuable feedback.

Thanks & Regards,

Manish

error.png (16.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Manish Gupta
Mar 23, 2017 at 03:31 AM
0

We got the solution for the problem. The problem was with helper table which is used within the course of activation. An activation itself deletes all content from the table before starting - but in our case, the DELETE statement is, however, failed with some error.

Steps followed to solve the problem:

1. Login as SYSTEM.

2. Create a binary export of the table using the command: export _SYS_REPO.ACTIVATION_HELPER2 as binary into '/tmp'

this will create a directory called index in /tmp on the DB server (This can be used in future if something goes wrong).

3. Make sure that _no_ activation at all is running in the system and only while no activations are running, truncate the table using the command: truncate table _SYS_REPO.ACTIVATION_HELPER2;

Share
10 |10000 characters needed characters left characters exceeded