Skip to Content
0

jConnect JDBC 4.1 or 4.2 driver?

Mar 16, 2017 at 09:01 PM

1.2k

avatar image
Former Member

I am searching for the latest jConnect JDBC driver, preferably one that is JDBC 4.1 or 4.2 compliant.

The newest jConnect driver I can find is:

$ java -jar jconn4.jar
jConnect (TM) for JDBC(TM)/16.0 GA (Build 27008)/P/EBF22326/JDK 1.6.0/jdbcmain/OPT/Sun Jan 12 09:41:12 PST 2014

I got this jar from the latest version of ASE available (16.0) and it is only JDBC 4.0 compliant.

Question:
Is there any JDBC 4.1 or 4.2 complaint driver available? If not, will any be released in the future?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Dawn Kim
Oct 02, 2017 at 04:38 PM
1

Hi,

The minimal version you can use is what is listed above is JDBC 4.0, java 1.6 from the output from above.

Please reference the books.: http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc39001.1600/doc/html/san1353997990864.html

Starting with SDK 15.5 we started to support java 1.7 JDBC 4.1.
So in SDK 15.7 and SDK 16.0 we do support java 1.7 JDBC 4.1.
In April of 2016 we started to support java 1.8, JDBC 4.2. This would be SDK 15.7 SP138 and higher and SDK 16.0 SP02 PL04 and higher.

Thanks,
Dawn Kim

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Dawn

In SDK 15.7 SP138, SP139, and 16.0 SP02 PL06 we see the version string embedded in jConnect still says it is built with java 1.6 and not 1.7 or 1.8. The packaging dependency information in the jconn4.jar file requires 1.6.

The use of JDK 1.6 means this is JDBC 4.0. JDBC 4.1 is showing from IBM as a minimum requirement for Websphere 9.0 series which is a problem for us as we are locked into supporting that.

Can you confirm when JDBC 4.1 / 4.2 will drop?

Thanks

Grant

0

Hi Grant,

The reason you see the build version is because that driver is compatible with java 1.6, 1.7 and 1.8.
When they drop any support for 1.6 and 1.7 they will upgrade that version string.
I don't see this happening until there is a major release drop. I am working on creating a feature request in for this.

Thanks,
Dawn Kim

0
Former Member

Hi Dawn, Using applications like Websphere which require 4.1 JDBC drivers we hit missing method exceptions on pool creation as some JDBC 4.1 (and 4.2) methods are not present - this is unavoidable and is causing huge issues as our Clients (and yours) are being encouraged to adopt later Java environments due to vulnerabilities.

The two methods that brought this to our attention are setSchema and getSchema in the Connection class. ASE doesn't support the concept of a schema in the generic sense and could simply ignore calls to setSchema and always return "dbo" for the getSchema (one other T-SQL database vendor took a similar approach); though I appreciate there would be complexity for SAP arising from IQ and SA as both support schema's. Other vendors support JDBC 4.1/4.2 without killing off 4.0 (JVM 1.6) by supplying one jar per JDBC release which may be an option for SAP too.

We do have a couple of open cases + CRs related to this.

Thanks
Grant

0
Dawn Kim
Oct 02, 2017 at 04:38 PM
0

Hi,

The minimal version you can use is what is listed above is JDBC 4.0, java 1.6 from the output from above.

Please reference the books.: http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc39001.1600/doc/html/san1353997990864.html

Starting with SDK 15.5 we started to support java 1.7 JDBC 4.1.
So in SDK 15.7 and SDK 16.0 we do support java 1.7 JDBC 4.1.
In April of 2016 we started to support java 1.8, JDBC 4.2. This would be SDK 15.7 SP138 and higher and SDK 16.0 SP02 PL04 and higher.

Thanks,
Dawn Kim

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member
0
avatar image
Former Member Apr 04 at 03:10 PM
0

Hi,

Here is the version of jConnect provided with SP02 PL04:

jConnect (TM) for JDBC(TM)/16.0 SP02 PL04 (Build 27293)/P/EBF26086/JDK 1.6.0/jdbcmain/OPT/Thu May 12 23:31:47 PDT 2016

It looks like it still references JDK 1.6.0 - are there any other versions of jConnect that can be used with the later version of JDK?

Thanks,

Mikhail

Share
10 |10000 characters needed characters left characters exceeded
Dawn Kim
May 25 at 05:21 PM
0

Hi,

You should be able to use that driver with java 1.8, just understand when we build the driver we use an older version so we can support 1.6, 1.7 and 1.8. You just need to download the version of java you want to use and use the jConnect driver you have.

Thanks,
Dawn Kim

Share
10 |10000 characters needed characters left characters exceeded