Skip to Content
0

crystal reports with multiple subreports Page N of M not working

Mar 16, 2017 at 06:48 PM

92

avatar image
Former Member

Hi All.

I developed crystal report in VS 2015 with multiple sub-reports. In page footer of main report I inserted special field Page N of M, but unfortunately when report is running and I change pages the page number doesn't change. The page number display only Page 1 of 1 on each page. How to fix that problem?

Thanks

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Dell Stinnett-Christy Mar 20, 2017 at 02:21 PM
0

You should look in the Section Expert of both the main report AND each of the subreports to make sure that "Reset page number after" isn't turned on.

Also, be aware that Page N of M can cause significant slowness in your report because Crystal will have to render the entire report - including ALL of the subreports - to get the total number of pages before it can display the first page. Without Page N of M or TotalPages, Crystal will show the first page of the report when it's ready and then render each page as the user goes to that page, which makes the report appear faster. If your report is just a few pages or if it is being exported or printed from an application without ever being displayed, this doesn't make much difference. However, if the report has many pages, this can have significant impact. I generally tell my clients to avoid using it if possible.

-Dell

Share
10 |10000 characters needed characters left characters exceeded