Skip to Content
0

Smartforms - missing street in address node on translated document

Mar 15, 2017 at 06:59 PM

117

avatar image
Former Member

Hi experts,

I created a smartform in english (as original language). It contains some standard text fields and an address node. I translated all the text fields in se63 from original to german and polish languages.

Now, I want to print this smartform in all mentioned languages. Everything is printed corretly beside the address node. On english version everything's ok, but on polish and german, the street is not printed within address node.

Maybe you would know why(?)

I would really appreciate some clues which will guide me to find the reason.

Thanks.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Mar 16, 2017 at 12:23 AM
0

Please check whether street in your address node has more number of characters in German and Polish compared to English because sometimes when you translate from one language to another, length of the characters might change and this may lead to space issues.

try to increase the window size where address node exist and check.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

It's not the window size problem.

The street and window are exactly the same in each language.

0
Jelena Perfiljeva
Mar 16, 2017 at 09:23 PM
0

Hard to tell remotely... Obvious thing to check - go to the place where the address is maintained (some master data, I assume?) and see if there is address print preview available. The screenshot below is from the customer master (similar feature exists in other transactions):

This should open a pop-up with the address and a button to change parameters. Try to login in different languages and check what results you get there with different parameters. You might also be using "international address version". Could be variety of reasons. Try to establish first whether it's an issue with the address data or standard address functionality or the form itself.

If there is no such button you might be able to test this by calling a standard FM for address formatting (forgot the name but you can easily find it in Google or SAP Help).

Post more details if there is still a question and include a screenshot of all the settings (General Attributes tab) in your address node.


image.jpg (15.6 kB)
Share
10 |10000 characters needed characters left characters exceeded