Skip to Content

Ora-01017 error starting J2EE: logon refused

I'm usig Web As 640 Abap+Java Sp16.

I was not able to logon anymore to the J2EE, both Visual Admin or vie the J2EE Start Page, so i did the following:

1) i checked in config tool wich was the ume.r3.connection.master.client

2)with SU01 in the Was 640, into the master client i changed the psw for J2EE_ADMIN

3) i logged with J2EE_ADMIN to define a definitive psw into the master client

4) with config tool i selected the 'Secure Store' node, and changed the parameter admin/password/J2EE_ADMIN

5) restarted the J2EE server and......

...it does not come up.

Into the jvm_bootstrap.log we see the msg :

"ORA-01017 invalid username/passoword, logon denied

What's wrong ? About wich user/psw is talking about and how I can modify it as I cannot start the configtool also ?

regards

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 10, 2006 at 12:35 PM

    Hi Mauro,

    we're having a similar problem with an Enterprise Portal WebAS 70 java stack.

    The system doesn't start any more and the error message displayed in the logfiles is:

    java.sql.SQLException: ORA-01017: invalid username/password; logon denied

    Would you please tell us if and how you solved your problem?

    Thanks in advance and best regards,

    Cornelia

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2006 at 09:14 PM

    It appears that you are changing the wrong password. Check the credentials of *DB (I do not recall the exact username) This user is also defined in the secure store.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Guys,

      actually the procedure for changing the password for ABAP/J2ee is same, you may use brtools or sqplus "ALTER USER <USEDID> IDENTIFIED by <PASSWORD>.

      for ABAP part you also need to change password in OPS$<SID>ADM.SAPUSER table, when using sqlplus.

      for J2ee, after changing the password from brtools or sqlplus, you need to update database user password using Offline configtool.

      hope this helps you.

      regards,

      uday.

  • author's profile photo Former Member
    Former Member
    Posted on Jan 03, 2014 at 10:18 PM

    after changing the SAPSR3DB schema password with brconnect, I have updated the schema password in configtool and could able to bringup the java portal.

    regards,

    Gowri Shankar.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.