Skip to Content
0

Problem with SAP B1 analytics powered by SAP HANA after upgrading to version 9.2 PL06

Mar 15, 2017 at 09:30 AM

781

avatar image

Hi All,

We have problem with SAP B1 analytics after upgrading to version 9.2 PL06.
When we try to use analytics we get the message: 'SAP Business One analytics powered by SAP HANA is not installed or cannot run properly'.
Upgrading the server components and company schemas are finished without errors.
After upgrade, companies are reinitialized and updated.

Please, can anyone help?

Thanks!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Ivan Stanic Mar 24, 2017 at 11:24 AM
0

Problem was with proper privileges for COMMON user on SBOCOMMON schema.

There was warning messages in the analyticService log:
[2017-02-27 14:18:51 WARN ] [http-nio-40000-exec-20] (com.sap.businessone.config.CompanyConfig:478) - SAP DBTech JDBC: [258]: insufficient privilege: Not authorized

In attached file you can find proper privileges for COMMON user.common-user.png


common-user.png (25.6 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Ivan

Do you know how i can change this inside the Studio? The privilegies are not be set on COMMON and SBCOMMON, I log with SYSTEM account.

0

Hi Marcel,

You can log in with SYSTEM user. Open Security/Users and double click on COMMON user to open settings for COMMON user. In the tab 'Object Privileges' you have to add SBOCOMMON schema and set privileges like in the attached pictures.

0