Skip to Content
author's profile photo Former Member
Former Member

XI Startup Error

Hi,

I am trying to start XI (SXMB_IFR), i am getting this error:

Exception

An internal error occurred. Contact you XI administrator

java.lang.NoClassDefFoundError

I tried SLD, its running fine..

Java Runtime is 1.4.2

<b>DETAILS:</b>

-


Exception Details

Exception class: java.lang.NoClassDefFoundError

-


Message

java.lang.NoClassDefFoundError

-


Stacktrace

Thrown:

java.lang.NoClassDefFoundError: null

at com.sap.aii.ibrep.server.transport.api.RepTransportServiceStartup.startupIbrepTransportServices(RepTransportServiceStartup.java:22)

at com.sap.aii.ibrep.server.applcomp.StartupCodeEntry.startup(StartupCodeEntry.java:426)

at com.sap.aii.ib.core.applcomp.IStartupCodeEntry.startupIfNotAlreadyDone(IStartupCodeEntry.java:33)

at com.sap.aii.ib.core.applcomp.ExplicitApplicationComponentImpl.startup(ExplicitApplicationComponentImpl.java:116)

at com.sap.aii.ib.core.applcomp.ExplicitApplicationComponents.startup(ExplicitApplicationComponents.java:374)

at com.sap.aii.ib.core.applcomp.ApplicationComponent.startup(ApplicationComponent.java:201)

at jsp_Main1223124322109._jspService(jsp_Main1223124322109.java:21)

at com.sap.engine.services.servlets_jsp.server.servlet.JSPServlet.service(JSPServlet.java:467)

at com.sap.engine.services.servlets_jsp.server.servlet.JSPServlet.service(JSPServlet.java:181)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:385)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:263)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:340)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:318)

at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:821)

at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:239)

at com.sap.engine.services.httpserver.server.Client.handle(Client.java:92)

at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:147)

at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:37)

at com.sap.engine.core.cluster.impl6.session.UnorderedChannel$MessageRunner.run(UnorderedChannel.java:71)

at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

at java.security.AccessController.doPrivileged(Native Method)

at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:94)

at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:162)

How to solve this?

Seshu

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 04, 2006 at 01:40 AM

    Hi Seshu,

    What happened? Did ur problem get solved?

    cheers,

    Prashanth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2006 at 11:22 PM

    Make sure in your Java Web Start -> preferences, the proxy is selected as none and the Java version enabled is Java 1.4 and not 1.5. Also are you trying to connect through your company VPN? Sometimes I have had that issue due to the wrong java version enabled in java Web Start or VPN issues.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Thanks for reply, i tried your option. i have only one Java 1.4 in my system and its enabled..

      Proxy also selected as none..

      I am using direct PC, not using VPN..

      Do i need to restart Java Web Start? how can i do that?

      any other options?

      Thanks

      Seshu

  • author's profile photo Former Member
    Former Member
    Posted on Aug 04, 2006 at 04:30 AM

    Hi Seshu,

    Some probable steps that you can try doing are:

    - It is recommended to have a minimum of JRE 1.4.2 or higher. But itÂ’s better not to have JRE 1.4.2_10 and above as it has been noticed to throw errors.

    - To avoid auto updates of J2SE to higher versions go to the control panel and open the Java Plug In icon. Browse to the update panel and uncheck the checkbox for Check for Updates Automatically.

    - Open Web Start and go to Preferences. In the General tab you will find 3 radio buttons for proxies. Select the None option.

    - Try clearing the cache folder Java Web Start >File >Preferences >Advanced >Clear Folder and then try downloading the jar files again.

    Also go through the following links:

    /people/sameer.shadab/blog/2005/11/27/java-web-start

    unable-to-launch-integration-builder

    Java Web Start

    Regards,

    Abhy

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2006 at 11:44 PM

    Start a command prompt and type <b>java -version</b> does it show your Java 1.4?

    Are you having the same issue for the Repository as well as the Directory?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 04, 2006 at 12:08 AM

    Click on the Administration tab on the Integration Builder homepage. Under the repository and directory tab what do you see as the jdk.version?

    Also where are you seeing 1.5.0_07? XI is not completely compatible to run on 1.5 it is much safer to use any version below that.

    Hope that helps.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      The Integration Builder page itself not displaying..

      about the version 1.5 its on the different system, where XI is running.. and the error i am getting on my notebook where i am getting trouble.

      Thanks

      Seshu

  • author's profile photo Former Member
    Former Member
    Posted on Aug 04, 2006 at 01:14 AM

    Hi Seshu,

    Do this...

    Go to this link in your computer..

    C:\Documents and Settings\<your user folder if any>\Application Data\Sun\Java\Deployment\cache\javaws\http and access the .jar files for your repository.

    I am telling you this because, your jar files could be corrupted. If they are corrupt, your jar file will have no icon( the windows logo icon will be there). Delete these jar files(only the error ones), and restart the repository. Just a hunch. Please be careful when u do this!

    Also look at this link :

    /people/shabarish.vijayakumar/blog/2006/02/13/unable-to-open-iresrid-xipipi-71-updated-for-pi-71-support

    cheers,

    Prashanth

    P.S Please mark helpful answers

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 04, 2006 at 01:16 AM

    Hi Seshu,

    Look at this also..

    https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/1688 [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken]

    cheers,

    Prashanth

    P.S Please mark helpful answers

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.