Skip to Content
avatar image
-1
Former Member

How to stop batch call is Odata v2 version In SAP WEB IDE?

Hi ,
I am using V2 version of OData in manifest.json file of SAP WEB IDE using UI5 template.I checked in network tabs of Developer tools its making batch call . Is it possible to stop default batch operation for default model in SAP WEB IDE for SAPUI5 template.

Thanks & Regards,
Abul

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Mar 14, 2017 at 07:50 PM

    As mentioned by Jun useBatch can be set at the time of model creation, in your case it is manifest.json

    below is the sample code of manifest.json under sap.ui5-->models

    	"sap.ui5": {
    		"_version": "1.1.0",
    		"dependencies": {
    			"minUI5Version": "1.30.0",
    			"libs": {
    				"sap.ui.core": {},
    				"sap.m": {},
    				"sap.ui.layout": {}
    			}
    		},
    		"contentDensities": {
    			"compact": true,
    			"cozy": true
    		},
    		"models": {
    			"i18n": {
    				"type": "sap.ui.model.resource.ResourceModel",
    				"settings": {
    					"bundleName": "com.daimler.i18n.i18n"
    				}
    			},
    			"serverModel": {
    				"type": "sap.ui.model.odata.v2.ODataModel",
    				"settings": {
    					"useBatch": false
    				},
    				"dataSource": "<your data source name>",
    				"preload": true
    			}
    		}
    	}
    
    Add comment
    10|10000 characters needed characters exceeded

  • Mar 14, 2017 at 03:40 AM
    -1
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Where I need add useBatch ? Can I add use batch in manifest.json file ?If yes, how we can do ?
      is it possible useBatch is in xml view when we bind table using items aggregation