Skip to Content

Hide Simulation button in Access Request GRC 10.1

Hey everyone,

How to hide the simulation button in Access Request without removing access to Risk Analysis altogether?

According to SAP note (1835754) it is controlled by authorization object GRAC_RA, with either activity 16 or 70. The reason they allow 2 different activity values (including "Administer"??) control this is beyond my understanding.

However, if I remove both activity values, then the tab Risk Violation goes away as well, so the users are unable to see the risks and approvers are unable to mitigate them.

I didn't check, but I suppose that access to ARA is also compromised.

Any reply is very welcome.

Thanks!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Mar 14, 2017 at 03:06 PM

    Hi Gustavo.

    In general, the best way to customize your screens when authorization objects don't solve your problem is the one described at

    https://blogs.sap.com/2013/09/04/customizing-access-request-and-approval-screens-in-grc-access-control/.

    Unfortunatelly, I think it won't work for these table toolbar buttons like "simulation".

    Before we found out this configuration way, we used a post-exit in method

    WDDOMODIFYVIEW of MAIN view of FPM_OIF_COMPONENT to change details of some of the components of request submission and approval screens. Maybe you can use it to hide your "simulation" button.

    Regards,

    Marcelo

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 14, 2017 at 03:03 PM

    Dear Gustavo,

    just simply change the visibility of the button from the configuration (&sap-config-mode=X).

    Cheers, Alessandro

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Alessandro.

      Sorry, I just saw your answer after posting mine.

      But I couldn't reach simulation button from the configuration screen. When I click at "Settings for Current Configuration" it shows me the table properties, but not its toolbar buttons.
      Am I doing something wrong?

      Thanks,

      Marcelo