Skip to Content
author's profile photo Former Member
Former Member

Data in SAP Application system not being updated by ABAP Server Proxy

Hi All,

I am facing a bit problem with ABAP Server Proxy. The Monitor SXMB_MONI in both systems XI and SAP Application system has chequered flad and says processing successfully completed. Field Queue status is also blank and the entries for mentioned queues are not existing which I think gets deleted after queue is processed.

But data is not being updated in SAP Table. Have checked proxy, its active nad method has no inconsitency. Applied external breakpoint but execution doesn't stop there. Any pointers please?

Thanks and Best Regards

Prashant Rajani

Add comment
10|10000 characters needed characters exceeded

5 Answers

  • Best Answer
    Posted on Aug 02, 2006 at 04:12 AM

    Hi,

    A recent blog discusses how to debug ABAP Proxies. take a look at it,

    /people/stefan.grube/blog/2006/07/28/xi-debug-your-inbound-abap-proxy-implementation

    Regards,

    Bhavesh

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 02, 2006 at 04:01 AM

    Hi,

    1. Have you put Commit work in the proxy after table update?

    2. look at this doc for debug:

    https://websmp202.sap-ag.de/~sapdownload/011000358700004815432004E/HowTo_debug_XI_30_Appli.pdf

    Regards

    Vijaya

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 02, 2006 at 07:34 AM

    Hi Prashant

    just a little trick, to control, if your proxies get executed:

     
    CALL FUNCTION 'SM02_ADD_MESSAGE'
    EXPORTING
    MESSAGE = 'hi prashant'
    EXPIRATION_DATE = SY-DATUM
    EXPIRATION_TIME = '220000'
    DELETE_TIME     = '220000'. 
    

    You should get a little message (you can debug with that: put a critical value instead of 'hi prashant'), if you exectute any transaction.

    Regards,

    Udo

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 02, 2006 at 04:41 AM

    Hi Prashanth,

    First up of all if u had made any changes in IR and ID just regnerate the server proxies in SAP system (in the intial screen of SPROXy select u r inbound interface and regnerate it and activate)

    And also once test u r proxy by going to sproxy clicl the inbound interface and goto the ABAP class and double click the method and test the method EXECUTE_ASYNCHRONOUS and see whether u r able to update in Data base or not?

    If not updated then check the method...

    Thanks and Regards,

    Sridhar

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 02, 2006 at 07:12 AM

    Thanks a bunch to all !!

    Bhavesh,

    Your link to Stefans's weblog 4098 was very much helpful.

    We are having 620 version of WAS and was not able to test other way. Report SPRX_TEST_INBOUND was of great help.

    Thanks and Best Regards

    Prashant Rajani

    Add comment
    10|10000 characters needed characters exceeded