Skip to Content
author's profile photo Former Member
Former Member

Unable to raise button Event in BlackBerry Emulator

Hi All,

I've created a WebDynpro Application which invokes a BAPI on click of a button(or Link to Action). This Application s running fine on IE.

I wanted t port this on a Blackberry device. I'm testing on a BlackBerry emulator. The first view is getting displayed properly, but I'm unable to click the Button which is displayed.

How to raise this event on the BlackBerry Emulator?

Thanks and regards

RK

Add comment
10|10000 characters needed characters exceeded

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 02, 2006 at 06:13 AM
    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 02, 2006 at 12:40 PM

    Hi Radha,

    Did you try to click on ENTER?

    Or open the menu by clicking on the wheel on the right hand side and select the option you want to use.

    kind regards

    Stefanie

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Thanks for looking at my post.

      @Heidi: I had already gone thru the link.

      @Stefanie: I am using BlackBerry Emulator for model 7520/7920. There is no wheel(I guess I didn't understand you properly). Yes I clicked on enter button.

      I'm a bit confused with the Button. In manual they said that the property 'Design' is ignored for Mobile Devices and at the same time they say if the Design is emphasized then you will get a softkey. I tried with Design Standard(which is default) and also Emphasized. I dont see any Softkey. I really don't know how a softkey looks like. I guess there will be a extra icon or button on the screen. But I don't see any.

      Thanks and regards

      RK

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2006 at 07:36 AM

    Hi Radha,

    okay, I see, the documentation is a little bit confusing, I will try to clarify this 😉

    The button is displayed as a link and there is no difference whether you click on this link or on any other link in the Blackberry emulator. Just try to call any website and check how links are working in Blackberry emulator. This way you can clarify where you problem is: on Blackberry emulator or on your application. Did you try your application in a Browser?

    Kind regards

    Stefanie

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      For people who are working on Emulators some suggestions:

      1. See to it that both the MDS version and Emulator versions are same.

      2. If you are unable to view WD application on BlackBerry Emulators 4.1, change the browser setting 'Emulation mode' to Microsoft IE instead of BlackBerry. Becasue when I keep it on BlackBerry mode, it gives me an error that WML is not well formed.

      3. But in Verison 3.7 you can keep in the BlackBerry mode itself.

      4. If you are not still able to run the App, allow to support Java Script and check for other related settings.

      5. If you are running 4.1 version, you need to have j2re version 1.5_06. Even if you install this version of j2re DON'T FORGET TO CHANGE THE JAVA_HOME.

  • author's profile photo Former Member
    Former Member
    Posted on Aug 04, 2006 at 03:22 AM

    Hi Radha

    We create a webDynpro application invokes bapi.

    Its running in dopod828 ( wince mobile 2003 )

    It works fine in IE.

    And we use a real dopod828 model to see the effects in embedded IE.

    Add comment
    10|10000 characters needed characters exceeded