Skip to Content
author's profile photo Former Member
Former Member

Whats Next after installing the Full Java Edtion2004-Trail

hi,

I carefully followed the instructions for installing the full Java Edition (NetWeaver 04s SP7) on my laptop (XP Professional with SP2). I didn't watch it every second, but it seemed to install okay. I entered the new P/W's etc. NetWeaver Developer Studio was installed a couple days b/4 trying NetWeaver (J2EE engine)... I see a SAPMMC was installed. I have selected the node "SAP Systems", right clicked and selected Start, but nothing seems to happen even after about 30 minutes. My laptop has a 2 gig dual processor with 2 gig of RAM. When I look at the services, I see SAP DB WWW is running (even before I try anything in the SAPMMC), but nothing else related to SAP is running.

1) Is there something that tells me what to do next? The Developer studio doesn't seem to recognize there is a J2EE engine (anywhere).

2) Is there a document that tells me what to do after the install? The document I went with, only talked about the install, and said it may take 15 minutes to start it, but didn't say what to start.

3) Is there a log file somewhere that will tell me for sure it installed okay?

4) Is there a log file that will help me understand why the SAPMMC doesn't do anything?

5) I recently completed the SAP classes JA300, JA310, JA331 and JA340. My JA310 instuctor seemed to think I could install NetWeaver on my Laptop with SP2. I was hoping to now try some of things we learned in class on my laptop. Is there something else I was supposed to install?

Thanks!

Perry S.

Add comment
10|10000 characters needed characters exceeded

3 Answers

  • Best Answer
    Posted on Aug 02, 2006 at 07:04 AM

    in SAP MMC, below sap systesm you should see a node called J2E , right click on that and click start.

    wait till it turns full green. (as per the installation documentation it takes about 45 to 100 minutes for the first time for the system to start up).

    once thats done

    you can call the following url to access portal.

    http://<your comuptername>:50100/irj or

    j2e home page

    http://<your comuptername>:50100/

    Regards

    Raja

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2006 at 05:18 AM

    Heavy sigh. This is turning out to be a lot of work to just try and get a NetWeaver J2EE Sandbox server.

    I decided to uninstall and re-install. I noticed that the install complained about my notebook computer name "Dell_Lat_02" because it was more than 13 characters which it isn't. I then stopped the install, and changed my laptop computer name to just DellLat02. This time, it only complained about the Operating System. I have Windows XP Professional SP2. I forced the install to continue and it completed. This time, I do see several things in the SAPMMC when I open it. By the way, I followed the following SDN article to help me install what I guess is the Portal version of NetWeaver?? SDN" target="_blank">www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/a818849b-0b01-0010-6795-c0c3e6559a30">SDN article to install the sneak preview...

    I right clicked on the top node in the SAPMMC and tried to start it. After only a minute or so, half of the icon turned green, and the other half yellow. I left it for about another 60 minutes, but it didn't change. When I select the last node (DellLat02 - J2EE Process table the server says it didn't start and has a -2 error code?? I right clicked and noticed something about Developer Info??. This seemed to show a log file. Sure enough, I found several places where the server failed to start. The messages were always: <b>Error occurred during initialization of VM Could not reserve enough space for object heap</b>.

    I searched SDN for these error codes and found some stuff about setting the MMAX property?? The article didn't provide much detail, and I couldn't figure out what, or where to do this, or even if it would fix my problem. It seemed like this is done from the Visual Administrator??? I found a go.bat that launched VA, but I wasn't sure what to do next. Why is there a problem with the heap settings showing up during right after the install, before I have done anything?

    Was it a mistake to try and install the portal version? My laptop has 2gig of Ram, 2gig processor and a bunch of diskspace.

    Also, the first node in the SAPMMC appears to be the DB, when I select it, the right part of the MMC says -24950 Authorization Failed. There is a place to put in a P/W, and when I put in the P/W that I used during the install, it seems to be happy, but when I click on it again, I get the same Auth. Failed message. Should the Windows OS User P/W match the P/W set during the install process? In my case, they are different.

    Any assistance would be appreciated.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      I had the same problem.

      It has occured bcos i had 512 MB RAM.

      SAP recommends

      At least 1 GB RAM, 2 GB are recommended.

      When I installed the same on 2 GB RAM. It worked.

      Other work around will be to increase the Virtual Memory and resume your installation.

      Regards

      Ajay

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2006 at 03:26 PM

    My laptop has 2gig of RAM. Looking through what logs I could find, I see and entry for 1023M which I guess is setting the heap size. I saw an article about heap size issues in SDN which said bump it up to 256M. I think I need to change -Xmx1023M to -Xmx256M. Any idea where this is done? I found a file called keydb.xml that seems to have a setting for -Xms, but when I changed this, it didn't take affect since the logs still said 1023. Thanks.

    Add comment
    10|10000 characters needed characters exceeded