Skip to Content

Problem remotely activating datasources in ECC from BW

Hi all,

I'm trying to use the new 04s method of activating datasources in my ECC source system, without the use of RSA5 in the source system. This entails replicating the 'D' version of the datasources in BW, then installing the datasource from Content in BW, which activates the datasource in both BW and ECC. New auth object S_RO_BCTRA is required in the source system to accomplish this.

As with most Dev environments I've worked in, the source system client for BW is NOT the configuration client in R/3 Dev. It is another client that contains data, but is locked for changes. When I try to install the datasources in BW, I receive the logon request for ECC, and then I get the message "Changes to Repository or cross-client Customizing is not allowed". I assume this is coming from ECC.

Is there a system setting in our ECC client that I'm missing? I can't believe that we would be forced to create our source system against the customizing client in order to activate the datasources. This would force us to have to copy all our Content from one source system to the other before we could extract data.

If this is the case, then we go back to the RSA5 method of activation.

Thanks,

Bryan

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 01, 2006 at 11:03 PM

    When you do a RSA5, you still get a transport request. It is the same. In activating a datasource, you are making changes in the source system/client, hence it needs to be open for such changes.

    Added -

    You can try logging to the customizing client (when you get ECC logon screen) and see if that works.

    Message was edited by: Ajay Das

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Bryan Koetting

      I understand what you mention.

      It is still the same, only thing is it now allows you to do it from BI (it still needs to create an 'active' version from 'delivery' version on the source system, and thus would need a change access to that system).

  • Posted on Aug 03, 2006 at 04:36 PM

    Thanks Ajay, you solved the mystery. When you get the logon prompt for R/3, overwrite the default source system client and enter the configuration client. You must have S_RS_BCTRA in the configuration client. It will then activate the datasource in both R/3 and BW.

    However, as it activates, you will receive the R/3 Transport Request dialog screen, within BW. You still have to place the datasource in a transport in R/3 to move to QA, just as is done with activation via RSA5. I was hoping that the new method of activation would avoid this step, but I see that that was not correct.

    Furthermore, since this new method is somewhat confusing with the R/3 logon screen and the transport request dialog from within BW, I would just as soon continue to use the old RSA5 method.

    Bryan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hey Bryan,

      Check the connection for the Source system in SM59, and specify the correct logon client as well, user and password. This should get you around the prompting of the screen.