Skip to Content
0

Tooltips in InfoCharts not appearing on hover after upgrade to latest DS

Mar 13, 2017 at 04:22 PM

82

avatar image

Hello,

Ever since we upgraded our DS to the latest patch, the tooltips have stopped working correctly on InfoCharts. They no longer appear when the user hovers over a column/bar/pie section. Instead, the user needs to click within the chart to bring the tooltip up:

Is that an expected behaviour? What's problematic about this is that the clicking action is usually bound to Onclick script, so when the user clicks on the Chart, the tooltip comes up for a fraction of a second and then the script is executed.

Is there a new setting which needs to be used to bring back the "old" tooltips? We are on IE11.

Thanks,

Agata

yc20u.png (8.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Shujaath Ali Syed Mar 19, 2017 at 01:49 PM
0

Hi Agata,

As per my observation, this happens in IE browser. In Chrome, it works on MouseHover (rather than Clicking ). But again, in chrome, when you actually click for drilldown, that tooltip stays persistently in the next (drilldown) page. This is a bug in DS i believe.

Regards,

Syed

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks! I thought it was IE issue. Will try to install Chrome or Firefox today and see if the behaviour is different.

0
Agata L. Mar 14, 2017 at 02:44 PM
0

Anyone, please, knows an answer to this?

Share
10 |10000 characters needed characters left characters exceeded
Agata L. Mar 17, 2017 at 10:25 AM
0

Nobody knows an answer to this?

Share
10 |10000 characters needed characters left characters exceeded
Agata L. Mar 20, 2017 at 01:51 PM
0

An update: tooltips do work onHover in Firefox:


vxuot.png (5.9 kB)
Share
10 |10000 characters needed characters left characters exceeded
syed shujaath ali Mar 21, 2017 at 04:28 PM
0

Hi Agata,

Tooltips did also worked on Chrome. But as i stated earlier, tooltip state persists from one page to another ( after drilldown ) even in Firefox. If we see this from a client perspective, not every company allows different browsers as part of their Group Policies. Many of the companies limit their employees to only IE ( no chrome or firefox ). In such cases, Users are bound to click on the graph to look at the tooltip. So, the solution is supposed to be coming from SAP itself on this. As it is more of a tool behavior, rather a browser issue. Considering, Design Studio dashboards should be running on HTML5. Isn't it?

Regards,

Syed

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Yes, my firm's policy only allows use of IE, so we are stuck with this broken tooltip. I hope they will fix it soon.

0