Skip to Content
author's profile photo Former Member
Former Member

Compatability of running composite application built using CAF

Hi all,

I want to know one basic question about using CAF tool.

Suppose if I use CAF of Netweaver 2004s (Netweaver AS 7.00) to build a composite application, is it possible to deploy the solution to the customer who is having Netweaver AS 620 or 630?

Appreciate your help. Thanks in advance

Regards

Guru

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Aug 01, 2006 at 11:59 AM

    Hi Gurunathan,

    That's not really possible. You need to deploy the solution to the same J2EE engine version as NWDS where you built your composite application.

    Even SP level must be the same. I recently met the problem that a composite application was built under NWDS 7.0 SP8 and even deployment to 7.0 SP7 J2EE engine was failed because of versions incompatibility!

    CAF, J2EE engine and NWDS versions must be the same, it's very important for consistency.

    Best regards,

    Aliaksei

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi all

      Thanks for all your valuable input.

      Can you explain the landscape of using CAF 7.0 and NWDI on AS 6.40 for develping the PCA?

      If we use this configuration for development, can we use CAF 2.0 and NWDS on AS 6.40 for deployment?

      If we do like that what are all the pros and cons?

      Thanks in advance

      Guru