Skip to Content
avatar image
Former Member

suppress blank space of blob field

Dear All,

I have a crystal report that have a blob field showing image from database.

All records in database dose not have the image but some are. I am showing blob field in details section and its working fine. To hide the blob field when it is null, i used conditional suppress and its working fine too.The problem is that when crystal reports suppress the blob field, its leave the blank space behind it for each record that dose not have image.

I tried hard did not get any way to recover this blank space. So, please help me out and give me a solution for the issue.

I am using Visual Studio 2010 and CRforVS.

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Mar 16, 2017 at 08:20 AM

    Hi Moovi,

    Try this please:

    1. Insert a Details B section

    2. Move the image to this section.

    3. Go to the Section Expert > Highlight Details a > Check 'Underlay following sections'.

    4. Highlight Details b > Check Suppress Blank Section.

    -Abhilash

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Abhilash,

      This is what i was look for. Many Thanks.

      I have one more concern that is there any way to manage blob image field height/width for different image sizes.

  • Mar 13, 2017 at 06:30 PM

    In the Section Expert there is as option to "Suppress Blank Section" .

    If the blob image is suppressed and there is nothing else in the section then "Suppress Blank Section" will do the work.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for the reply...

      I tried this but detail section contains other fields too which have values.