Skip to Content
avatar image
Former Member

The JDK installed in directory /usr/java14 does not support the 64 bit data

I'm installing the Java Add-in for the ECC 60 SR1 and suddendly during the instalation of the module for the creation od the db schema I recive the error:

"The JDK installed in directory /usr/java14 does not support the 64 bit data model"

I'm using the JSDK 1.4_2 SR3 for AIX, and till now this JSDK was the rigth JSDK for the installation.

What does it means ? DO I have to download the latest JSDK for AIX ?

The only thing changed at Os level before of that error on the JSDK is the installation of the latest perating system patch, but I should be very surprised if there is a relation with the error I'm reciving now.

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 15, 2006 at 04:41 AM

    Hi,

    I am also facing the same problem & wanna check if u got the solution for the problem. If yes please do let me know.

    my id is manubagga@gmail.com.

    This is going to be a great help...

    Regards,

    Manu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Benny Schaich-Lebek

      I do have the same problem. For me the java worked with AIX 5.2 but failed with AIX 5.3 😔

      bash-2.05b# which java

      /usr/java14/.private142/bin/java

      bash-2.05b# java -fullversion

      java full version "J2RE 1.4.2 IBM AIX build ca142-20060421 (SR5)"

      bash-2.05b# uname -a

      AIX vcsaix101 2 5 00C888AC4C00

      bash-2.05b# which java

      /usr/java14/.private142/bin/java

      bash-2.05b# java -fullversion

      java full version "J2RE 1.4.2 IBM AIX build ca142-20060421 (SR5)"

      bash-2.05b# uname -a

      AIX vcsaix11 3 5 00C7690E4C00

      Any idea?

      Regards,

      Venkat

  • avatar image
    Former Member
    Jun 13, 2007 at 05:07 PM

    Hello All,

    For any new Netweaver Installations SAP recommends that you use the new J9 JDK. I would refer to note 716604 for AIX. Regarding the 64 bit data model, it sounds like you have a 32 bit JDK installed. For 64 bit systems a 64 bit JDK is sometimes required. This is installed in addition to the 32 bit one, i.e you dont have to uninstall the 32 bit JDK.

    Regards,

    David

    Add comment
    10|10000 characters needed characters exceeded