Skip to Content
0

Resume AMDP Debugger for * has encountered a Problem

Mar 13, 2017 at 10:09 AM

135

avatar image
Former Member

Hello Experts,

we created our first AMDP based classes and methods. I now want to start testing and debugging, but running in the following problem in the Eclipse based ADT when creating a break point in Eclipse in the AMDP Method:

After that message, all further breakpoints I want to create only trigger the message

This will be the state until I terminate the AMDP Debugger:

but when I do and create a new break point, the same error as above is shown.

Debugging with the HANA Stored Procedure debugger works, but I would prefer the more powerful AMDP debugger.

I'm using eclipse NEON in 64 bit (4.6.2) and ADT for Hana in Version 2.73.0. The System is a Hana 1.0 with SPS 12 (1.00.122.05). I have to connect threw a firewall if the customer. We opened the ports 80xx, 1443, 33xx, 36xx, 443xx and 32xx, where xx is the instance number ob the ABAP System.

Can anyone help?

Thanks and kind regards

batp9.png (20.6 kB)
4ioz4.png (29.1 kB)
s0rex.png (3.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Armin Beil
Mar 16, 2017 at 04:02 PM
0

Hello Riccardo,

there is also an open customer incident for the same issue. We are currently working on this.

Best regards,
Armin

Share
10 |10000 characters needed characters left characters exceeded
Armin Beil
Mar 24, 2017 at 08:01 AM
0

Hello Riccardo,

thank you for helping us to identify and analyze this issue. The correction for the AMDP Debugger is planned to be shipped with the next version of ABAP Development Tools (2.77). This version is planned to be available for customers about beginning of may.

@Others: Workaround for this issue is to use SAP JRE or Oracle JRE instead of IBM JRE.

Best regards,
Armin

Share
10 |10000 characters needed characters left characters exceeded