Skip to Content
author's profile photo Former Member
Former Member

Error while configuring credential for Adobe Forms

Hi,

While configuring Credential i am getting an error as popup. But when I click on OK, I am able to see the .pfx file in the top.

<b>Error Details:</b>

An error occurred while updating the credential expiry for alias 'ReaderRights':

com.adobe.service.sap.configuration.ConfigurationException:Unable to load keystore from credential. Please ensure the password is correct.

We have not received any password from SAP, only there was one password to download the file.

After all I am trying print forms, not an interactive form. But when I deploy and run it shows error.

<b>Error Details:</b>

com.sap.tc.webdynpro.services.exceptions.WDRuntimeException: Error during call to AdobeDocumentServer: Processing exception during a "UsageRights" operation.

Request start time: Sat Nov 26 11:54:53 GMT+05:30 2005

com.adobe.ProcessingError: Credential login error while applying usage rights to PDF: C:\WINNT\Temp\adobewa_J2E_00_1015779131\DM8997397967410486296.dir\DM-8285166541278556430.tmp

Specific error information:

$$$/PDF/PDFCredentialLoginFailure2=error while logging into credential ^0

GeneralError: Operation failed.

SecurityHandler.login:-1:

Could not open Digital ID file with the password provided. Please try again.

Please suggest the solution.

Thanks,

SA.

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jul 31, 2006 at 09:14 AM

    Hello,

    Be sure that all the services related to Adobe Document Services are started (IIOP in dispatcher and server, Document services, PDF manipulation module and XML form module). You have to start them before registering the credential.

    Also, did you register the correct password provided with the credential ?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Just an info.

      I am in SP14.

      and I am able to logon in http://<server>:<port>/AdobeDocumentServices/Config with user ADSUser. and the test works fine.

      Thanks,

      SA