Skip to Content
0

Public IP Access HANA Express 2.0 Installed in Personal Desktop Server

Mar 11, 2017 at 08:38 AM

125

avatar image

Dear,

I installed the HANA Express 2.0(VM Image) in the VMWare 12 pro in my personal server. Everything is fine, I can access all services in the intranet(192.168.XXX.XXX). The Net Adapter is bridge mode.

Then I tried to build the internet access. To do this, I do the following beyonds the HANA install:
1. Get a DDNS. This works very well
2. My public IP is located in my Router. So I need a mapping. I mapped internet IP+Port to my VMWare IP+Port where VMWare is, port is 8090.
3. Test the 8090 port, it works well says: XEngine is up and running.
4. Then I tried to test webide, port is 53075. I do the mapping the router again.
5. However, the test of 53075 failed. The error says
XXX.XXX.XXX.XXX refused to connect.
ERR_CONNECTION_REFUSED
6. Eclipse either can not access the HANA in my VMWare through Internet.
7. Both steps 5 and 6 work very well in the intranet.
8. I googled a lot in last days and found a relevant video. But should I configure that xscontroller.ini according to the video? I tried that with public IP but that leads XS Controller can't be launched.

https://www.youtube.com/watch?v=iYOlVnew-to&t=1s


Thanks in advance, everyone ...

Best regards,
Thanks,

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Steven CHEN Mar 11, 2017 at 03:15 PM
0

Some update, when I used 8090 port with public IP address for the WebIDE, it works...
http://<public IP>:8090/sap/hana/ide/

So I think 53075 is blocked by some configuration. Anyway, my requirement is to make HANA accessible to my HANA Studio ... Now it doesn't work.

Share
10 |10000 characters needed characters left characters exceeded
Steven CHEN Mar 11, 2017 at 03:53 PM
0

Some more update, my Eclipse can connect HANA DB after I set my HANA VM as DMZ Host in the router.
But 53075 port is yet accessible through Public IP.

Share
10 |10000 characters needed characters left characters exceeded