Skip to Content
author's profile photo Former Member
Former Member

Problem with Table?

Hi All,

I have a table and two webservices.On the basis of certain search criteria,the table will get populatedwith data.

In the search screen i am passing values to both the webservices. Then in return my table is getting populated with data from both the webservices.

For this sake I have created a value node with value attribites according to the number of fields required for the table.

I have one column as a requirement as a link.I am binding this value node to the table and then the table is ready for the data incoming.

But the column LINK is not related to any webservices.

The LINK has the record "click to view".

The text click to view should be disabled for the row or the data coming from one webservice and should be enabled for the other.

While binding the table with the value node , I am setting the editor as linkToURL and binding property as enabled.

Then in the program I am setting it false for one for loop which is responsible for one webservice and otherwise for the other.

But when the table is geeting loaded, the LINK is appearing disabled permanently.

Can any one resolve the issue and help me out with some other approach. Looking forward to you.

Regards

DK

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jul 26, 2006 at 10:46 AM

    Let "Rows" be the table data source node.

    Add a value node "State" (cardinality=1:1, selection=1:1, singleton=false) under "Rows".

    Add an attribute "LinkEnabled" (type=boolean) inside "State".

    Bind property Link.enabled of table cell editor to attribute "LinkEnabled".

    At the event handler (or method) where you fill the data source node, add code like this:

    IRowsElement row = ...;
    boolean enbled = linkEnabled(row);
    row.nodeState().currentStateElement().setLinkEnabled(enabled);
    

    Predicate "linkEnabled" returns true if the link at that row should be enabled.

    Armin

    Add comment
    10|10000 characters needed characters exceeded