Skip to Content
0

SRM-Portal with buttons are being unresponsive issue.

Mar 10, 2017 at 04:52 PM

129

avatar image

I am facing the above issue when i am clicking the next button of the form opened in new window in the IE11browser

10 |10000 characters needed characters left characters exceeded

Hi Epperla,

When posting questions, it is helpful to provide as much relevant detail as you can, in order to assist others in providing relevant and meaningful solutions. What version of Portal? Is this the Enterprise Portal with an SRM iView, or are you perhaps referring to the "portal-independent" native web UI in SRM? What version of SRM? What steps have you taken to troubleshoot this? What document mode is your IE11 browser operating in?

Please have a look at How to Ask Good Questions to Get Good Answers for tips.

Cheers,
Matt

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Santarshi Samanta
Mar 13, 2017 at 06:47 AM
2

Hi Epperla

As per the issue description that you have provided, what I understood is that when you are clicking on the SRM application in portal, it is opening in a new window in IE 11 browser and in that window, the buttons are not responsive and clickable.

Please correct me if I am wrong.

Can you refer to the below KBA and perform the small test given under the cause section of it.

2424773 - Display and Rendering issue in IE 11 in Portal

If the behavior is same as given in the cause section, then you have to follow one of the two recommendation given in the resolution part of it.

Regards

Santarshi Samanta

Show 7 Share
10 |10000 characters needed characters left characters exceeded

Hi Santarshi,

Thanks for your reply, but our client are using the custom ajax framework page. But your answer suitable for the standard ajax framework page. Please ping me the solutions for the custom ajax framework page for the above issue

Thanks,

Eppera.

0

Hi Eppera

As mentioned earlier, did you perform the small test given under the cause section of it. Is it working as explained there ?

If that is the case then with your custom desktop, you can go ahead in changeing the "Launch in New Window" propert to "Display in separate headerless portal window (standards mode)" of the iview, which opens an application (iview/page) in a new window which behaves as a standards application and that should work for you.

Regards

Santarshi Samanta

0

Dear Santarshi,

I was checked with above two answers given by you, still i am getting the same issue. intially portal is opened in quirks mode means document mode =5(default). after click on the hyperlink of vendor then we get the application form in new window with buttons in a standard mode that means document mode=Edge(default) and if i want chage the document mode from "Edge" to "5" the following errors are occurred. Please find the following attached screen shotscapture.pngcapture1.pngcapture2.png

capture.png (696.2 kB)
capture1.png (456.5 kB)
capture2.png (38.2 kB)
0

Hi Eppera

Can you first make sure what is the rendering mode required for the application which you are launching ?

From the last reply I see that Portal is in Quirks mode and the application is launching in new window and taking

document mode=Edge, which means its launching in Edge mode. At this time is your application launching correctly ?

If yes, then why are you changing the document mode from "Edge" to "5" ?

If your application requires Quirks(5) mode of rendering then you can simply launch the application in the Portal content area itself, when you are using Ajax Framework Page.

On changing the Modes the screen will show that error, then try to refresh the screen again by doing the right click,

and then it will launch again with the forced rendering mode value.

If still you are not clear, then I will suggest you to follow each step from the below blog :

https://blogs.sap.com/2015/07/07/9-steps-to-solve-portal-rendering-issues-in-ie/

Regards

Santarshi Samanta

0

Hi Santarshi,

Thanks for your all replies but issue is still not resolved. For the above issue we are using the following

We are using Portal 7.5, IE-11 and custom Ajax Framework Page. and as per my view portal is opened in quirks mode (IE=5) and the application opened in window is in standard mode(IE= Edge), But if we are change the document mode as 5 in applcation opened in window its working. But after refreshing it takes as Edge mode for that how we are change the permanently document mode as 5 in application opened in window.

Thanks,

Epperla.

0

Hi Santarshi,

I forgot tell u here the type of application is BSP. This BSP application is integrated into the portal 7.5.

Thanks,

Chandra.

0

Hi Santarshi,

Please give the me the any updates for the above issue, still it is not resolved and it is very high priority pls help us.

Thanks,

Chandra.

0