Skip to Content
author's profile photo Former Member
Former Member

Options > Data Path not working.

Hi,

In XML Forms Builder, I set the Options > Data Path to "/documents/KMReview". I expect that when I create a document by using the edit form from within "Content management > Explorer > News", the xml documents be created and saved within ""/documents/KMReview". But the xml documents are instead created in "/documents/News".

Can anyone suggest why this happens?

Regards,

Sunil

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 25, 2006 at 06:13 PM

    Hi Sunil,

    If you want to work using form builder you should do:

    1. Create your project, don't forget to generate it.

    2. In System Administration-System Configuration-KM-CM-Form-Based Publishing-Forms Availability-Folder Settings-> create a new item in which you define where you can launch your form.

    3. Create a new km navigation iview, assign it NewsExplorer or NewsBrowser layout set, depending on you want to create o only explorer the xml files created.

    This km navigation iview must point the folder that you define in 2 step.

    Patricio.

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2006 at 05:44 PM

    Its working now.

    The iView that I enquired about is the iview from which xml documents are created. (there are two iviews, xml document browser and xml document creator)

    So the path mentioned in this overrides the path specified in Options > Data Path.

    Patricio, you are right. I should have followed the three steps diligently, for the sap supplied "News Authoring" iView has the path specified as /documents/News. That is why the xml documents were getting created in this location.

    Best Regards,

    Sunil

    Add comment
    10|10000 characters needed characters exceeded