$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

Cannot start instance(MaxDB) during installing Netweaver 7.5

Mar 10, 2017 at 10:05 AM

163

avatar image

Hi experts,

I met a problem "cannot start instance" during installing NetWeaver 7.5 on Redhat7.3. Could you please help check why this happen?

OS info:

[root@mo-36ffb5ac4 sapdata]# cat /etc/*release

NAME="Red Hat Enterprise Linux Server"

VERSION="7.3 (Maipo)"

My installation log:

And I tried to start the instance manually. This is the following logs:

[root@mo-36ffb5ac4 bin]# ./dbmcli -d LDB -u sqdldb,pxE8FZt24001 db_online

Error! Connection failed to node (local) for database LDB: -24950,ERR_USRFAIL: User authorization failed

My system SID is LDS and DB's sid is LDB.

Many thanks.

BR

Alex

capture24.png (354.9 kB)
capture25.png (40.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Bartosz Jarkowski Mar 10, 2017 at 10:09 AM
1

Hi,

1) You can try to start system manually from command line

2) If that won't help please provide us with dev_disp log file

Best regards

Bartosz

Show 10 Share
10 |10000 characters needed characters left characters exceeded

Hi Bartosz,

1) I tried start the instance in command line. The following are the result.

[root@mo-36ffb5ac4 data]# su - sqdldb

Last login: Fri Mar 10 10:57:51 UTC 2017 on pts/0

mo-36ffb5ac4:sqdldb 5> dbmcli -d ldb -U c db_online

OK

And I reran sapinst and same error popped up.

2) dev-disp.txt Hope I upload the proper file for you. If it is not correct, please contact me and tell me which I should upload.

Many Thanks.

BR

Alex

dev-disp.txt (67.2 kB)
0

Hi,

this step tries to start SAP Instance, not database. Database is already running.

Anyway I checked your log file. I think I know what is going on, but to double check can you please paste the content of /etc/hosts file?

Best regards

Bartosz

0
Bartosz Jarkowski

Hi Bartosz,

[root@mo-36ffb5ac4 ~]# cat /etc/hosts

127.0.0.1 mo-36ffb5ac4.mo.sap.corp mo-36ffb5ac4

127.0.0.1 localhost.localdomain localhost

127.0.0.1 localhost4.localdomain4 localhost4

# The following lines are desirable for IPv6 capable hosts

::1 mo-36ffb5ac4.mo.sap.corp mo-36ffb5ac4

::1 localhost.localdomain localhost

::1 localhost6.localdomain6 localhost6

I didn't change this file. I just ensure the hostname is correct.

[root@mo-36ffb5ac4 ~]# hostname

mo-36ffb5ac4

[root@mo-36ffb5ac4 ~]# hostname -f

mo-36ffb5ac4.mo.sap.corp

Do I must change this hosts file?

Many thanks.

BR

Alex

0

The problem is that your hostname is assosciated with the loopback interface, which is not correct. You should read SAP Notes prior to starting the install, for example:

2002167 - Red Hat Enterprise Linux 7.x: Installation and Upgrade

Anyway, to fix your issue please correct following entry in your /etc/hosts file (change 127.0.0.1 to your actual IP address):

127.0.0.1 mo-36ffb5ac4.mo.sap.corp mo-36ffb5ac4

Then continue with the installation process.

Best regards

Bartosz

1

You are correct ;-)

Cheers!

Isaías

1
Bartosz Jarkowski

Hi Bartosz,

I changed the hosts file as you said. But when I reboot the server and continue my installation,the instance still cannot be started. Then I tried install a new system(I rebooted the server). But during I input the database id, there is error popped up. And I changed the file as popped solution. It still cannot work.

Please review my files.

127.0.0.1 localhost.localdomain localhost

10.9.36.29 mo-36ffb5ac4.mo.sap.corp mo-36ffb5ac4

127.0.0.1 localhost4.localdomain4 localhost4

Sorry for this inconvenience. I modified the file as the note said. But there is still errors popped up.

BR

Alex

capture27.png (121.8 kB)
0

Hi,

What is the outcome of following commands:

A) ping mo-36ffb5ac4.mo.sap.corp

b) hostname -s

Best regards

Bartosz

0
Show more comments

Great! Congratulation !

Best regards

Bartosz

0
Juan Reyes
Mar 13, 2017 at 09:52 AM
0

If the DB is the issue dev_disp wont help it does not show database connection issues... can you post dev_w0?

https://blogs.sap.com/2013/06/20/logical-basic-abap-system-start-troubleshooting-sequence/

Regards, JP

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hi Juan,

Thank you very much for your answer. Bartosz has already helped me find out why the instance cannot be started. I missed one OS configuration step(modify the /etc/hosts file) before Netweaver installed. After I modified the file as the Notes 2002167, I met another problem.

Do you have clue to resolve this problem?

Thank you very much.

BR

Alex

capture27.png (121.8 kB)
0

Yes, the clue is on the text above...

Go to your host file (/etc/hosts) and add the entries required..

127.0.0.1 localhost

<ip of your host> <hostname>

this are basic requirements when setting up a system... read the installation guide.

Regards, JP

0

Hi Juan,

I did this as the solution in the error message. But the error still popped up. I don't know how to fix it.

Many thanks.

BR

Alex

0

change your entry for the reverse lookup to point to your host

127.0.0.1 mo-36ffb5ac4

Regards, JP

0

Hi Juan

I resolved this problem and successfully installed Netweaver 7.5.

Thank you very much for your help.

BR

Alex

0
James Zhang
Mar 14, 2017 at 12:44 AM
0

Hi Alex,

"./dbmcli -d LDB -u sqdldb,pxE8FZt24001 db_online"

Do you have superdba or control user? sqdldb is not like a default db user.

Best regards,
James

Share
10 |10000 characters needed characters left characters exceeded