Skip to Content
2

How to configure the Analytical Table in a Smart Chart

Mar 10, 2017 at 08:06 AM

369

avatar image

Hello fellow Sappies,

I tried to implement an Analytical Table into a SmartChart, which threw this error:

where do i have to configure the SmartTable to sum up the given measures regarding my selected dimension and do i have to additionally configure the metadata.xml ?

Thanks in advance!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Fabio F. Mar 16, 2017 at 09:34 AM
2

Hi, I have the same problem.

Did you found a solution?

Thanks

Share
10 |10000 characters needed characters left characters exceeded
Lukas Oelker Mar 16, 2017 at 12:07 PM
1

Hi Fabio,
unfortunately I am still facing said problems.

I tried different configurations in my backend, which led to different outputs but never to the expected values. There was always a repetition of values, so I'm thinking there is a problem with the grouping function.

What was your approach on the matter? If you provide some screenshots of your code / metadata.xml we could merge our approaches to find a solution.

Share
10 |10000 characters needed characters left characters exceeded
Fabio F. Mar 27, 2017 at 08:15 AM
1

Hi Lukas,

I tried different solutions but the problem persists.

In detail I show data directly from DB (EKKO table) via SADL model but the partial\total sum is

referred only to the first record.

These are my metadata and view files:


md.jpg (103.2 kB)
vw.jpg (51.1 kB)
Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Fabio,
I was able to solve my grouping problem. The AnalyticalTable not only expects you to define dimensions& measures, which all were defined by an unique key, you also have to set them as key in your metadata.
So grouping now works... but only if i do not allow the sum functions on the measures. If i do allow them to be summed, it seems that the analytical table interpret the measures as a new dimension leading to a repetition of my entries.

I saw that you are not using any Vocabularies. Is there a reason for that?

Best
Lukas

0

Hi Lukas,

I'm trying to set all fields as key in metadata but the result is the same because I have the repetition of records.

Can you please share your metadata so I can see what I wrong?

I'm not using any Vocabularies because it's just a test for me and set the annotations directly in the define method.

Just for curiosity, I'm trying to use smart variant into the same example (smart table): I insert the app into FLP, activate all service in sicf for the sapui5 flexibility service but I can write the saved variants into backend but I cannot load because I have this error:

Failed to load resource: the server responded with a status of 404 (Not Found): http://myserver/sap/bc/lrep/flex/data/smart.Component ==> where smart is my namespace.

Have you ever tried this service?

Bye,

Fabio

0

Hi Fabio,
try to set only the dimensions as key.

The metadata coming from my server:

(don't mind the false values in visible -> that was to test s.th.)

For Vocabularies i used LineItem, which manages the initially shown values - handles the error on startup& is way faster than always selecting the values you want to see.

did you define a Component.js on your server?

i followed the steps in this link:

https://help.sap.com/saphelp_uiaddon10/helpdata/en/a8/e55aa2f8bc4127923b20685a6d1621/content.htm

and decided for me that i won't need a variant management (for now). I recall that i had some issues with access privileges for certain transactions.

Lukas

componentjs.png (24.8 kB)
vocabular.png (128.8 kB)
0