Skip to Content
avatar image
Former Member

Crosstab report does not display in CR Viewer after upgrade

We are using CR for VS 2013. All of our reports worked before the upgrading from CR version 13.0 to SP 19. Now one of our reports no longer works. The only distinct characteristic with this report is that it is a Crosstab report. Is there any know solutions for this? Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 14, 2017 at 04:59 PM

    I think I may have stumbled across the problem. The application was built as 32bit. The SP19 DLLs we loaded are 64bit. I need to do some more research but that's my theory right now. I will need to figure out a way to "convert" my app to 64bit or install the SP19 32bit DLLs. Am I making any sense?

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 09, 2017 at 04:46 PM

    Hi William,

    What error are you getting? if you remove the CT does it work?

    Check all of your formula and fix any that may have unknown field references.

    Try using KBA 2163438 and preview using the report with Saved Data and see if that works.

    Don

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 09, 2017 at 09:19 PM

    There isn't a specific error. The report viewer opens but it is empty. We have 11 other reports in the application and they all work but they are standard reports, not crosstab.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 10, 2017 at 11:22 PM

    Seems to be an issue with the Crosstab dll.

    Is this a Windows or WEB App?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      The DLLs I have for my project are:

      CrystalDecisions.CrystalReports.Engine 13.0.2000.0

      CrystalDecisions.ReportSource 13.0.2000.0

      CrystalDecisions.Shared 13.0.2000.0

      CrystalDecisions.Windows.Forms 13.0.2000.0

      Are these correct? Am I missing anything?
  • Mar 12, 2017 at 11:54 AM

    Reports with CrossTabs work just fine for me (using same SP19). So something unique to your report is at play.
    Gradually simplify things in the report to find out what causes the problem.
    Is this a case where an empty main report is linked to a subreport?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      The DLLs I have for my project are:

      CrystalDecisions.CrystalReports.Engine 13.0.2000.0

      CrystalDecisions.ReportSource 13.0.2000.0

      CrystalDecisions.Shared 13.0.2000.0

      CrystalDecisions.Windows.Forms 13.0.2000.0

  • avatar image
    Former Member
    Mar 14, 2017 at 05:57 PM

    That was the solution. I went into Configuration Manager and converted the app to 64bit, upgraded all my reports to the current SP and now everything is working. Thanks for any comments you made.

    Add comment
    10|10000 characters needed characters exceeded