Skip to Content
avatar image
Former Member

Web IDE Build / Space Enablement Tool does not work

Hi all,

I have just installed a SAP HANA 2.0 Platform Edition with XS Advance (XSA) for evaluation purposes in terms of IoT scenarios. Components have been patched to the latest available patch level.

While the whole platforms works fine in general, there is a really strange issue with building applications in the (on premise) Web IDE:

In IE11 browser, I got an error message " Object doesn't support property or method 'assign' " when starting build, so no build possible.

When using Chrome browser, there is an error with the builder: "Build of test02 failed. The builder is either unavailable or outdated. To solve this, try again in a few minutes, and if the problem persists, contact your administrator to deploy or update the builder using the Space Enablement tool".

So I tried to call the Space Enablement tool in order to redeploy the Build Service, but the only thing I get is an empty page with title "Space Enablement". In short words: The Space Enablement tool does not work for any reason, and I have tried several browsers.

Unfortunately, I didn't find a solution for this issue when searching for similar problems in blogs etc.

Is there a workaround for this issue? Can I redeploy certain components (by using "xs install" for example) in order to get this solved? Or are there special requirements on front end side for the (quite new) Web IDE patch, for example certain browser or java versions?

Any kind of help is appriciated...

Thanks and kind regards

Heiko

Add comment
10|10000 characters needed characters exceeded

  • Former Member

    I have the same issue.

  • I have the same issue. When i try to enable the space with the space enablement tool I get:

    Deploy Service is not available in space <XXX> for user <XXX>.

    org HANAExpress not found Could not deploy the builder. Cause: Could not deploy the builder MTA.. Could not deploy the builder MTA. The builder deployment has finished with status: FAILED in space dev.

    What is strange to me is that it cannot find HanaExpress org. my dev space is part of other org than HANAExpress.

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Aug 04, 2017 at 05:50 AM
    -2

    Pls check logic database if is enable for XS Advanced.

    Add comment
    10|10000 characters needed characters exceeded

  • May 03, 2017 at 06:50 AM

    Hi,

    What is the SAP WebIDE version you are using?
    Could you please provide log files?

    Regards,

    Offer.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 20, 2017 at 11:38 AM

    Hi all,

    I have the similar issue - Enable button in Space enablement does not work. When I click on it nothing happens and in server response which I can see only in Developer tools I see the message "Operation not permited".

    Could anyone assist?

    Thanks in advance!

    Olja

    HANA developer

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 24 at 04:28 PM

    I am having the same issue (blank page after logging in to Space Enablement tool) with Hana Express edition. Did anyone ever find a solution to this?

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 25 at 02:36 PM

    can you navigate to the XSA cockpit ... to make sure you have a SPACE create... if you are using the XSA HXE you should have 2 default SPACES created, development and SAP...

    I have seen the blank SPACE drop down when my web ide timed out... refresh your web ide to see if that is refreshed.

    Add comment
    10|10000 characters needed characters exceeded