Skip to Content
0

CSS created in local mode is not working in BI platform

Mar 09, 2017 at 09:32 AM

168

avatar image

Dear Gurus,

I have an issue with my design studio application which I created using DS 1.6 SP3 in local mode and have maintained all the CSS in the application file only.

However, when I imported this application in the DS 1.6 Sp3 using BI platform mode, I have lost all the CSS changes and not sure what is going wrong.

Since the CSS file is integrated within the application now in DS 1.6 and I believe there is no need to maintain a custom CSS file and upload it on BI platform in case of DS 1.6.

Does anyone has any idea what is the route cause of this issue or do I have to go to old school method and maintain an external CSS file and upload it on the BI platform.

Regards
Sumit

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Tammy Powlas
Mar 09, 2017 at 10:17 AM
2

Hi Sumit - please see the Design Studio support wiki:

https://wiki.scn.sap.com/wiki/display/BOBJ/Design+Studio+-+Support+Page+For+Client

If your CSS is missing on the BI Platform you will need to upload it to the BI Platform

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Thanks Tammy,

I have uploaded the CSS file on BI platform but I can still see the css changes which I made in the local mode are not reflecting.

Also I could see that the CSV data which I have used for crosstabs is showing as data not available. Usually, when I exported this file in the local mode, the data is saved in the local repository. So, do I need to save these CSV files on the server now.

0

Hi Sumit - sounded like from your original post that you didn't upload the CSS.

CSV as a datasource is intended for offline use; and now you are uploading that to the BI Platform? Please help me understand why

See Karol's post here: https://blogs.sap.com/2015/12/03/design-studio-16-view-on-offline-data-csv-files/

0

We have an OSS Incident opened with SAP regarding this exact issue. In our case the CSS file is definitely on the BI Platform server - what we are seeing is that when we inspect an element with a css class there is a 404 error accessing the CSS file. The error is related to the way the date information is structured in the "version" section of the URL. Incident is currently with SAP Development for analysis... We are also seeing issues with image files, json files, etc...

0

We have seen this issue also recently. Did you restart your tomcat? Is the environment cluster or single node?

0

We have tried restarting Tomcat (single node) - nothing. We tried a few other things, like placing CSS and Image files directly on Tomcat server and referencing via absolute URL - same issue... No updates from SAP...

0