Skip to Content
0
Former Member
Jul 14, 2006 at 11:09 AM

EP7.0 and CRM5.0 business package issue

11 Views

Hi All,

I have 2004s EP and deplyoed CRM5.0 business package in to portal. We have crm5.0 back end. Connectivity is succesful between portal and CRM. SSO also implemented.

I have assigned some roles of CMRBP to portal when I try to access any of the iviews it is displaying following error:

<b>Portal Runtime Error

An exception occurred while processing a request for :

iView : N/A

Component Name : N/A

Unable to parse template '<PSID.CRMUnique>'; the problem occured at position 15. Cannot process expression PSID.CRMUnique.</b>

For each iview a session id is populated automatically and the property for this is <PSID.CRMUnique>, this property is not being retrieved by all the BSP iviews, what I did was remove the property completely <PSID.CRMUnique> and left a blank value and ran the pre-view it works!

But why this property is not getting populated ? will there be any problem if I remove the entry <PSID.CRMUnique>, from iviews?

Apart from this it is also displaying error in dynamic navigation part of every CRM role :

the follwoing is the error

<b>Portal Runtime Error

An exception occurred while processing a request for :

iView : pcd:portal_content/com.sap.pct/specialist/com.sap.pct.crm/com.sap.pct.crm.roles/com.sap.pct.crm.accountmanager/com.sap.pct.crm.am.acc.accountmgmt/com.sap.pct.crm.am.acc.accounts/com.sap.pct.crm.am.customer_defaults/relatedItems/DynamicNavigation/com.sap.pct.crm.quickcreate

Component Name : null

Page could not create the iView.</b>

Appreciate your help

With Regards,

Ravi