Skip to Content
0

Unable to create DTP on BW/4HANA for Datasource > IOBJ or ADSO

Mar 08, 2017 at 10:17 AM

948

avatar image

I have a brand new BW/4HANA system and have just started modelling some InfoObjects and an ADSO, and I created an ODSO over a HANA table (on the same server as B4).

Now I want to load data, but I got stuck.

I successfully created a transformation between a datasource (generated from ODSO) and an InfoObject in order to load some texts.

The dataflow is pictured below. As you can see, there is an active transformation on 'GI_STATUS'. When I use the context menu I get the option to create a DTP, and the dialogue opens (also pictured in the screenshot below).

In this dialogue, I have tried to select the transformation, source and targt, only source, but whatever I try the 'Ok' button remains greyed out.

What am I missing here?

whereismydtp.png (68.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Jan Van Ansem Mar 17, 2017 at 08:55 PM
0

Hi Rajesh, we got an answer from SAP (as we logged an issue there).

It turns out that the issue has been resolved in HANA Studio BW Modelling tools version 1.17.7

We were on 1.17.4. After upgrading it worked.

Just look for the new tools in the software download center on support.sap.com

Search term 'bw modeling tools 1.17' should lead you to file: SAPBWMTE00_1-70002534.ZIP

To be honest, it is not terribly clear what the fix is. There is a note (2420864) but that doesn't even mention 'DTP'.

Also, when you look at the content detail, you can only see that you are downloading 1.17 - not whether you are downloading 1.17.4 or 1.17.7 - and what the differences might be.

When you have downloaded the ZIP file, you can check the contents and see it refers to components of version 1.17.7.

I hope this helps,

Jan.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 18, 2017 at 08:40 AM
1

Hi Jan,

You will be able to create a DTP with your current version by following this workaround:

Hover over your source element and go to the connection arrow in the context pad Drag and drop the connection arrow to your target element. A new modeled connection will be created. You can see it by the increased number next to the grey DTP Icon.

Now go into the context menu of your target element and open the DTP sub menu. You will find there a new entry "Create <YOUR_SOURCE> -> <YOUR_TARGET>". Choose it and the DTP creation starts.

If you go back to the data flow editor after creating your DTP you will notice that the grey icon is now blue. This indicates that your modeled connection got created.

Please let me know if you further face issues

Regards

Githen

Share
10 |10000 characters needed characters left characters exceeded
Jan Van Ansem Mar 08, 2017 at 06:49 PM
0

I did some further investigation and found the following:

When I create a transformation between two ADSO's, I have an option in the context menu to create a DTP.
It takes me to a SAPGUI screen (emulated in HANA Studio) and that works.

But for an InfoObject, this option is not in the context menu:

It starts to look like this is a bug.... or is there still something I am not getting?

Thanks in advance for your help,

Jan.


Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 15, 2017 at 10:54 PM
0

Hi Jan,

I am having the same issue. Did you find a solution to enable the OK button for an InfoObject DTP?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 15, 2017 at 07:27 AM
0

In you Data flow screen select the datasource ( click on and hold the mouse button) and drag the data source to the target ADSO and leave the mouse button. you DTP will be created. once DTP is created right click display DTP and activate.

This is a Modeling tool version issue this issue will be resolve in next version 1.18

Thanks

Samit

Share
10 |10000 characters needed characters left characters exceeded