Skip to Content
author's profile photo
Former Member

spool columns width

Hi,

I have a report which is run a background job and I'm outputting to the spool. While setting the spool parameters, we set the layout for eg. X_65_255. This is causing only 255 columns to appear in the screen and my report columns are getting truncated after a particular number. How do I adjust my spool so that I can see all my report columns. Is there a way to do this?

Regards,

Vijay

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

7 Answers

  • Posted on Jul 12, 2006 at 05:00 AM

    Hi,

    Goto SPAD transaction => Extended Administration => Device Types=> Format Types .

    You would get a list. These are the different available format types. You can use any of these or you can create your own format type by specifiying the column width and use the same.

    Best regards,

    Prashant

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 12, 2006 at 05:28 AM

    Hi,

    Transaction SP01 would serve the purpose.

    Program name RSPOSP01NR.

    Best regards,

    Prashant

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 12, 2006 at 05:43 AM

    Hi,

    Specify the layout as DINA3 instead of X_65_255. The maximum horizontal width for A4 size paper is 255. So change it to DINA3.

    Best regards,

    Prashant

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 12, 2006 at 05:52 AM

    Hi,

    You would require authorization for using SPAD transaction. Contact your BASIS person.

    Best regards,

    Prashant

    PS : Please reward useful answers

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I'm having authorization for SPAD. But it is not allowing me to edit anything. Nor is there an edit button or a create button anywhere. Using which transaction do I create these format types? Is it also SPAD

      Regards,

      Vijay

  • Posted on Jul 12, 2006 at 06:04 AM

    Hi,

    Goto SPAD transaction => Extended Administration => Device Types ..... <b>Click CHANGE ICON</b>

    => Format Types .

    Best regards,

    Prashant

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Jul 12, 2006 at 06:38 AM

    Hi,

    Try to use this page format as the default "X_65_1024/4".

    Check this SAP Note...

    Number: 409339

    Symptom

    As of Release 4.6x, the ABAP list processor can generate spool requests for ABAP lists with a width > 255 columns.During SAP spooler printing, however, only the top of the report lines is printed and the rest is "chopped off" at the bottom of the sheet.

    Other terms

    ABAP, lists, print parameter, LINE-SIZE

    Reason and Prerequisites

    Creating "wide" lists on the screen (that is, lists in the SAPGUI with more than 255 columns) was already introduced by the ABAP list processor for 4.0B. However, these lists cannot be printed out in the width used on screens before Release 4.6.

    In older releases (for example, 4.0B, 4.5B), you were not able to generate spool requests at all for lists with a width of more than 255 columns:

    Error message PT 026: " No. of columns > 255, no standard print-out possible".

    Therefore, we did not have the problem described here of non-existing device-type support in 4.0/4.5 for printing out "wide" lists.

    Up to and including 4.6C, no SAP device types are available that support print formats for lists as wide as these(> 255 characters).Since 3.0A, all SAP device types already support a maximum list width of 255 characters with format (device format) X_65_255.

    Solution

    When you create the spool request and a print dialog box appears, enter a column width of maximum 255 in the "Number of columns" field.

    As of Release 4.6D, you have the option of printing via a PC with SAPlpd using device type SWIN with the new format X_65_1024/4 (see Note 213382).

    Thanks and Regards,

    Bharat Kumar Reddy.V

    Message was edited by: Bharat Reddy V

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Aug 21, 2007 at 01:43 PM

    Hi,

    Try to follow these steps:

    1. As the "Output Device" (for a background job) choose a printer that has the "Device Type" set as "SWIN". If such a device isn't available, use the following steps:

    1.1. Use the SPAD transaction.

    1.2. Select "Output Devices".

    1.3. Press the "Change" button (first button, looks like a pencil) or the "F8" key.

    1.4. Press the "Create" button (should have appeared) or "SHIFT + F1".

    1.5. Set the "Device Type" as "SWIN", the "Device Class" as "Standard Printer", the access method as "F:...." and the "Host Printer" as "__DEFAULT".

    1.6. Save the printer and now it should appear in the list of available output devices.

    2. After choosing the output device, press the "Properties" button.

    3. Set the "Format" as "X_65_1024/4". If you want to set this format as default (for current client, user and output device), select "Settings" and then "Copy Settings" (after having modified any other useful option).

    4. Run the background job.

    5. View the job by using transaction SP01.

    6. Check the box next to your job.

    7. Press the "Display in maximum width" button (seventh button, next to the "glasses") or press "SHIFT + F4".

    Now your report should appear in full size (if the total number of characters on all columns doesn't exceed 1023).

    Please let me know if this solves your problem.

    Regards,

    Adrian

    Add comment
    10|10000 characters needed characters exceeded