Skip to Content
0

HCP / Spatial / SRID Conversion / TrexUpdate failed

Mar 07, 2017 at 03:26 PM

94

avatar image

Hi,

I have an HCP Hana istance. We loaded a shape file in a table using 3044 SRID (which is the SRID used in the GIS system).

Then we need to convert the SRID from 3044 to 3857. So we first created a table

and then perform an insert

but an error is returned and it seems an OOM (Out of Memory) problem or a bug with HANA

Could not execute 'insert into CDR_3857 select OBJECTID, IDSAP, DENOMINAZI, WA_LATITUD, WA_LONGITU, ...' in 40 ms 456 µs . [129]: transaction rolled back by an internal error: TrexUpdate failed on table 'HER_LA:CDR_3857' with error: commitOptimizeAttributes() failed with rc=1610088, message not found; table 'HER_LA:CDR_3857$delta_1, rc=1610088 - enforce TX rollback

Suggestions? Already happened to some of you?

Thank you

table.png (1.2 kB)
table-content2.png (27.4 kB)
table-create.png (5.3 kB)
insert.png (6.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Benedict Venmani Felix Mar 07, 2017 at 06:44 PM
2

Hello Leonardo,

Can you try this,

CREATE COLUMN TABLE CDR_3857(<fields>,

SHAPE ST_GEOMETRY(3857));

Mention the SRID when you specify the geometry type. Provided the SRID is available in your system. If you dont provide the SRID it will default to '0'.

Also,

INSERT INTO CDR_3857 SELECT <fields>, SHAPE.ST_SRID(3044).ST_TRANSFORM(3857)

I have not tried this INSERT though :)

Share
10 |10000 characters needed characters left characters exceeded
Leonardo Romanato Mar 07, 2017 at 07:22 PM
1

Thank you Benedict! Now it works!

Share
10 |10000 characters needed characters left characters exceeded