Skip to Content
avatar image
Former Member

Unable to launch UI5 Application from Portal UWL

Dear All,

Our requirement is as follows

  • We need to launch an UI5 application when the user clicks on UWL work item.

In order to achieve this functionality we have added our task in SWFVISU transaction with visualization type UI5_BSP and added below values under visualization parameters.

APPLICATION - <Application name>

When I try to open the work item from UWL , it launches standard SAP GUI instead of the custom UI5 application that we configured in SWFVISU.

I tried to check the XML configuration and I did not find the task that we configured in SWFVISU.

Even I tried to re-register the system in portal under

System administration -> Universal Worklist & Workflow -> Universal Worklist Administration

But unable to find the task in the web flow Item definition (XML configuration). Could you please direct some pointers to achieve this scenario.

Thank you,

Harsha

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Mar 07, 2017 at 07:40 PM

    Hi Harsha

    You've mentioned that you've performed the re-registration of the connector, right? This should be enough, theoretically.

    Have you tried clearing the UWL cache after having performed the re-registration?

    Check SAP KBA 2141647 on how to clear the UWL cache.

    As you've made the configuration on SWFVISU, you should have the configuration reflected in a Low priority XML file. Have you checked on that file with Low priority?

    Let us know the updates.

    Regards,
    Armando

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Armando Zaro

      Hi Armando,

      Is there any possibility that you can assist me with this? I have tried following the note recommendation but it still launches SAP GUI

  • avatar image
    Former Member
    Sep 06, 2017 at 03:37 PM

    Hi Harsha,

    I have exactly the same requirement. were you able to resolve the issue? if so can you help me out? I have tried editing the xml file as mentioned in the note but unfortunately have been unsuccessful.

    Regards,

    Yaseen

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 16 at 06:16 AM

    I have the same issue... Any luck with this guys?

    Add comment
    10|10000 characters needed characters exceeded