Skip to Content
0

Unable to launch UI5 Application from Portal UWL

Mar 07, 2017 at 02:15 PM

255

avatar image
Former Member

Dear All,

Our requirement is as follows

  • We need to launch an UI5 application when the user clicks on UWL work item.

In order to achieve this functionality we have added our task in SWFVISU transaction with visualization type UI5_BSP and added below values under visualization parameters.

APPLICATION - <Application name>

When I try to open the work item from UWL , it launches standard SAP GUI instead of the custom UI5 application that we configured in SWFVISU.

I tried to check the XML configuration and I did not find the task that we configured in SWFVISU.

Even I tried to re-register the system in portal under

System administration -> Universal Worklist & Workflow -> Universal Worklist Administration

But unable to find the task in the web flow Item definition (XML configuration). Could you please direct some pointers to achieve this scenario.

Thank you,

Harsha

10 |10000 characters needed characters left characters exceeded

Hi Harsha,

Did you manage to resolve this issue?

I am trying to achieve exactly the same thing, still struggling - please check my thread and respond:

Opening a fiori app fom portal UWL

Regards,

Ashish Shah

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Armando Zaro
Mar 07, 2017 at 07:40 PM
0

Hi Harsha

You've mentioned that you've performed the re-registration of the connector, right? This should be enough, theoretically.

Have you tried clearing the UWL cache after having performed the re-registration?

Check SAP KBA 2141647 on how to clear the UWL cache.

As you've made the configuration on SWFVISU, you should have the configuration reflected in a Low priority XML file. Have you checked on that file with Low priority?

Let us know the updates.

Regards,
Armando

Show 5 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Armando,

Thank you for the quick response..

yes, I have performed re-registration but was unable to find the task . Even I tried to clear the cache but no luck !!!

We have checked the Low priority XML file but did not able to find the task. Issue seems to be only with visualization type UI5_BSP as I could see the task in the XML file when I configured the task with other visualization types such as ABAP web dynpro, BSP standard etc.,

Thank you,

Harsha

0

Hi Harsha

Possibly it is the case that the UWL is not considering the new visualization type UI5_BSP.

As a short term solution/workaround, I would advise you to create an XML file in the UWL and define a UWL action by using the UI5Launcher. Check following note which introduces it:
1924320 - UWL launcher enhancements

Kind regards,
Armando

0
Former Member
Armando Zaro

Hi Armando,

Is there any possibility that you can assist me with this? I have tried following the note recommendation but it still launches SAP GUI

0
Former Member

Hi Armando,

Thank you.. We were able to solve the issue.

We have designed the custom XML file for the UI5launcher as suggested in the note 1924320. Now we are able to open the UI5 application from UWL.

May I ask a question out of curiosity that why we are not able to see the task in the XML file( even in the low priority XML file) when we use the visualization type UI5_BSP?? Is there any specific reason .

Once again thank you for your wonderful suggestions... :)

Thank you

Harsha

1

Hi Harsha

Thanks for your comments.

Indeed this is something which is not yet 100% clear for me too. As far as I could check right now the UI5_BSP seems to be designed to be used with My Inbox, as you can find in below SAP Blog:
https://blogs.sap.com/2016/05/31/my-inbox-open-task-swfvisu-configuration/

In the current UWL design, this launcher UI5_BSP is not recognized (and nor considered) when the UWL is doing the registration of the connector, and this is why no corresponding UWL action is seen in the generated XML.

Kind regards,
Armando

0
avatar image
Former Member Sep 06, 2017 at 03:37 PM
0

Hi Harsha,

I have exactly the same requirement. were you able to resolve the issue? if so can you help me out? I have tried editing the xml file as mentioned in the note but unfortunately have been unsuccessful.

Regards,

Yaseen

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 16 at 06:16 AM
0

I have the same issue... Any luck with this guys?

Share
10 |10000 characters needed characters left characters exceeded