Skip to Content

Badi does not execute at runtime

Hello All,

We are having a problem trying to implement BADI BBP_CATALOG_TRANSFER with method ENRICH_ITEM_DATA / interface IF_EX_BBP_CATALOG_TRANSFER

We have created a new implementation for this BADI that has generated a new class (in se19). The implementation is visible in V_ext_act and the class and implementation is visible in SXC_CLASS.

The implementation is active, the class is active and the class has the correct method IF_EX_BBP_CATALOG_TRANSFER~ENRICH_ITEM_DATA

However

When performing a where used list for this BADI our new implementation does not appear. Instead we are still seeing an old implementation that has been deleted. In addition the source code that we have implemented as part of the exit is not being executed during run time.

We think that we have covered all the steps required but may be missing something vital ???

I know this is a tricky one but any help would be greatly appreciated.

Thanks very much in advance

Regards

Ketan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jul 10, 2006 at 09:37 AM

    Hello

    Just wanted to add that in addition to our custom implementations, the class implementation

    CL_EX_BBP_CATALOG_TRANSFER

    is also associated with this BADI in the where used list.

    When I look at this in our QA environment this class is not associated only the custom developed classes are associated.

    Not sure why?

    Any ideas would be appreciated..

    Regards

    Add comment
    10|10000 characters needed characters exceeded