Skip to Content
1

Eclipse : Breakpoint could not be created at this line

Mar 07, 2017 at 09:20 AM

262

avatar image

Hello

Regularly I cannot set a breakpoint in my abap classes in eclipse. I get the message

'Breakpoint could not be created at this line'. Setting the breakpoint at the same place in the R3 development environment works fine.

The line where I want to put the breakpoint is definitely a valid line to put a breakpoint, so it's no data initialization or comment line.

I think it has something to do with the synchronization of the code between eclipse and the server but I'm sure. Maybe it is because of our system set-up, but I would like to know if anyone of you has the same problem and maybe a solution ?

Thanks in advance

Koen

10 |10000 characters needed characters left characters exceeded

I have a similar situation here.

Variant A: A breakpoint just created does not trigger the debugger. 80 % for public methods of global classes, 100 % for methods in test classes of class-pools.

Variant B: I get an error when setting a breakpoint, 80 % and 100 %, see Variant A.

In the same places, the statements BREAK-POINT or BREAK MYUNAME do trigger the ADT debugger.

Regarding Armin Beil's questions:
This does not fix itself by waiting a minute or a day, not even after shutting down my PC.
I tried reactivating the source with without actual changes, does not work.
The source used for testing is a global class no one else ever touched.

My setup:
ABAP Core Development Tools (Developer Edition) Version 2.73.3;
Eclipse Platform "Mars 3" Version 4.6.3.M20170301-0400;
Connected to a 750 sp05 backend;

Use these steps to reproduce:

+++ variant A:

A1: change source of [ a public class-method of a global class in its class pool | a private method in a test-class in a class-pool ]
A2: activate object.
A3: do not change anything.
A4: activate object again.
A5: set breakpoint in executable line of this method by double clicking left of the code.
A6: see the blue dot with tooltip "line breakpoint PROGRAM_NAME line ### for user MYUNAME".
A7: press F8 to test the object.
A8: click method execution icon.
A9: debugger does not stop, method result shows it came across the statement i wanted to debug.

+++ Variant B, braching after executing step A6:

B1: double click the blue dot to remove the breakpoint.
B2: double click at the same spot the create the breakpoint where it just seemed to be.
B3: read error message box with title "toggle breakpoint" and text "breakpoint could not be created at this line" [ok].

.

0

Hi Peter,

thanks for the detailed description. Unfortunately I was not able to reproduce the issue (A & B) using ADT 2.73.3, Eclipse Platform 4.6.3.v20170301-0400 Neon 3 (4.6 is Neon, so I guess you are also using Neon not Mars) and a 7.50 SP04 backend (feature equivalent to SP5).

Since I cannot reproduce it we would need some traces from your side and maybe also have to remotely connect to your system for further processing. Therefore I would ask you to create a customer incident for this issue for component BC-DWB-AIE-TST.

In case you experience variant B again please also open the breakpoints view and check whether the line number written in the text matches the line number of the editor where the blue dot is drawn.

Best regards,
Armin

0

thank you armin, you are right, 4.6 is neon, of course. i will open a customer incident including the contents from the breakpoint view. peter.

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Armin Beil
Mar 17, 2017 at 02:22 PM
1

Hi Koen,

since you ensured that the line itself is valid for a breakpoint (contains executable ABAP) the issue might be related to synchronization of source or synchronization of runtime artifacts.

Is the issue reliable reproducible also if you waited some time in between two tries? If the problem occurs the next time could you please try to activate the source (even if there are no recent changes) and then retry creating the breakpoint? Do you often work on same sources with multiple people?

Best regards,
Armin

Share
10 |10000 characters needed characters left characters exceeded
Justin Loranger Jun 27, 2017 at 05:58 PM
0

I have also had this happen if I have not yet activated the object.

Share
10 |10000 characters needed characters left characters exceeded